aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 15:42:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 19:23:24 +0000
commit8173fdbecbc1ef23edf550907ae8aab1ed818845 (patch)
tree8abc04b106c38e7c1b18ed33d9a43994d391f137
parentce6671d33cc4ffeafa879120ee5eae28c11bb887 (diff)
downloadaports-8173fdbecbc1ef23edf550907ae8aab1ed818845.tar.bz2
aports-8173fdbecbc1ef23edf550907ae8aab1ed818845.tar.xz
community/libraw1394: modernize
-rw-r--r--community/libraw1394/APKBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/community/libraw1394/APKBUILD b/community/libraw1394/APKBUILD
index 27430b0d37..602f6e9711 100644
--- a/community/libraw1394/APKBUILD
+++ b/community/libraw1394/APKBUILD
@@ -1,22 +1,16 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=libraw1394
pkgver=2.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Library to provide access to Linux 1394 subsystem"
url="https://sourceforge.net/projects/libraw1394"
arch="all"
-license="LGPL-2.1+"
-depends=
-depends_dev=
+license="LGPL-2.1-or-later"
makedepends="linux-headers"
-install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="https://kernel.org/pub/linux/libs/ieee1394/$pkgname-$pkgver.tar.xz"
-
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://kernel.org/pub/linux/libs/ieee1394/libraw1394-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,12 +23,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}