aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-24 17:05:31 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2020-04-29 12:14:48 +0000
commit8299de333bd41be1fe498d779f960ae216b9b5d7 (patch)
treecc44b2c50fa21545d9f3039b5bdbb91eb91fb452
parent7323eb6d10cef1a4079404c65a975094b09e5851 (diff)
downloadaports-8299de333bd41be1fe498d779f960ae216b9b5d7.tar.bz2
aports-8299de333bd41be1fe498d779f960ae216b9b5d7.tar.xz
community/kdsoap: new aport
-rw-r--r--community/kdsoap/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/kdsoap/APKBUILD b/community/kdsoap/APKBUILD
new file mode 100644
index 0000000000..705271d85a
--- /dev/null
+++ b/community/kdsoap/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kdsoap
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="Additional components to increase the functionality of KIO"
+arch="all !armhf" # armhf blocked by extra-cmake-modules
+url="https://www.kdab.com/products/kd-soap"
+license="LGPL-2.1-only AND LGPL-3.0-only AND (GPL-2.0-only OR GPL-3.0-only) AND AGPL-3.0-only"
+depends_dev="qt5-qtbase-dev"
+makedepends="$depends_dev cmake doxygen"
+source="https://github.com/KDAB/KDSoap/releases/download/kdsoap-$pkgver/kdsoap-$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+options="!check" # No tests
+
+build() {
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+# Building tests break without network access
+# -DKDSoap_TESTS=ON
+ cmake --build build
+}
+
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+sha512sums="051804ba3dc09b30353787d4345fd023c42956bae8322dc1c846322983a50fe1a1e5b06988d339218290958043bf7ebfd049c3cdfa61da9e28f3fee4f052b93d kdsoap-1.9.0.tar.gz"