aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 13:04:09 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 13:59:38 -0300
commit8395403f80832e63a9fff33fd8d23b9e7dafb04e (patch)
treed79b2c33368b9e96ae4f1c4a66454902637df724
parent6ee5c144dc93436feb2cd0aa086eeb695d552690 (diff)
downloadaports-8395403f80832e63a9fff33fd8d23b9e7dafb04e.tar.bz2
aports-8395403f80832e63a9fff33fd8d23b9e7dafb04e.tar.xz
community/flatbuffers: modernize
-rw-r--r--community/flatbuffers/APKBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/community/flatbuffers/APKBUILD b/community/flatbuffers/APKBUILD
index 7ee6305063..c11a709510 100644
--- a/community/flatbuffers/APKBUILD
+++ b/community/flatbuffers/APKBUILD
@@ -1,38 +1,31 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=flatbuffers
pkgver=1.11.0
-pkgrel=0
+pkgrel=1
pkgdesc="Memory Efficient Serialization Library"
url="https://google.github.io/flatbuffers/"
arch="all !s390x"
license="Apache-2.0"
-depends=""
-depends_dev=""
-makedepends="$depends_dev cmake"
-install=""
+makedepends="cmake"
subpackages="$pkgname-dev"
source="flatbuffers-$pkgver.tar.gz::https://github.com/google/flatbuffers/archive/v$pkgver.tar.gz
0001-Add-detection-of-strtoull_l-function.patch"
-builddir="$srcdir/flatbuffers-$pkgver"
build() {
- mkdir -p "$builddir"/build
- cd "$builddir"/build
- cmake .. \
+ cmake -B build . \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DFLATBUFFERS_BUILD_SHAREDLIB=on \
- -DCMAKE_INSTALL_LIBDIR=lib
- make
+ -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=None
+ make -C build
}
check() {
- cd "$builddir"/build
- make test
+ make -C build test
}
package() {
- cd "$builddir"/build
- make install DESTDIR="$pkgdir"
+ make install -C build DESTDIR="$pkgdir"
install -Dm755 "$builddir"/build/flatc \
"$pkgdir"/usr/bin/flatc
}