aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-01 14:44:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-01 15:22:21 -0300
commit85385006e2acc5ac59420d6cd872fa1f241b5d5f (patch)
tree4ee9ae4209195aecd84e5e0fa81e6d9981290e1a
parentad44c7816d91061ff10ca977c9365dd5e8ed3932 (diff)
downloadaports-85385006e2acc5ac59420d6cd872fa1f241b5d5f.tar.bz2
aports-85385006e2acc5ac59420d6cd872fa1f241b5d5f.tar.xz
community/abiword: add enchant-2
-rw-r--r--community/abiword/APKBUILD12
-rw-r--r--community/abiword/enchant.patch30
2 files changed, 40 insertions, 2 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index c00f053d3b..6eed2183dd 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=3.0.4
-pkgrel=2
+pkgrel=3
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
arch="all !s390x"
options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
-makedepends="gtk+3.0-dev readline-dev libgsf-dev fribidi-dev wv-dev
+makedepends="gtk+3.0-dev readline-dev libgsf-dev enchant2-dev fribidi-dev wv-dev
popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice-dev pcre-dev
libxslt-dev perl"
@@ -31,6 +31,14 @@ done
source="http://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+
+ sed -i 's/enchant >=/enchant-2 >=/' configure.ac
+
+ autoreconf -fi
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/abiword/enchant.patch b/community/abiword/enchant.patch
new file mode 100644
index 0000000000..0b46496de0
--- /dev/null
+++ b/community/abiword/enchant.patch
@@ -0,0 +1,30 @@
+--- abiword-3.0.2/src/af/xap/xp/enchant_checker.cpp.orig 2013-04-07 13:53:03.000000000 +0000
++++ abiword-3.0.2/src/af/xap/xp/enchant_checker.cpp 2017-11-19 22:54:41.236180298 +0000
+@@ -127,7 +127,7 @@
+ pvSugg->addItem (ucszSugg);
+ }
+
+- enchant_dict_free_suggestions (m_dict, suggestions);
++ enchant_dict_free_string_list (m_dict, suggestions);
+ }
+
+ return pvSugg;
+@@ -139,7 +139,7 @@
+
+ if (word && len) {
+ UT_UTF8String utf8 (word, len);
+- enchant_dict_add_to_personal (m_dict, utf8.utf8_str(), utf8.byteLength());
++ enchant_dict_add (m_dict, utf8.utf8_str(), utf8.byteLength());
+ return true;
+ }
+ return false;
+@@ -150,7 +150,7 @@
+ UT_return_val_if_fail (m_dict, false);
+
+ UT_UTF8String ignore (toCorrect, toCorrectLen);
+- return enchant_dict_is_in_session (m_dict, ignore.utf8_str(), ignore.byteLength()) != 0;
++ return enchant_dict_is_added (m_dict, ignore.utf8_str(), ignore.byteLength()) != 0;
+ }
+
+ void EnchantChecker::ignoreWord (const UT_UCSChar *toCorrect, size_t toCorrectLen)
+