aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-12 13:51:59 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 10:48:38 -0300
commit86739e67abbce4f0360ec34a0b1abb7eb78623db (patch)
treefbf0f515ea0056d9a40dac1a8c24adfb7d32cf5d
parent15a08e31dde3fc03fbbba239e3214b0e454be521 (diff)
downloadaports-86739e67abbce4f0360ec34a0b1abb7eb78623db.tar.bz2
aports-86739e67abbce4f0360ec34a0b1abb7eb78623db.tar.xz
community/kolourpaint: move from testing
-rw-r--r--community/kolourpaint/APKBUILD (renamed from testing/kolourpaint/APKBUILD)13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/kolourpaint/APKBUILD b/community/kolourpaint/APKBUILD
index 2905f034d1..4e18a6d263 100644
--- a/testing/kolourpaint/APKBUILD
+++ b/community/kolourpaint/APKBUILD
@@ -8,11 +8,18 @@ url="http://www.kolourpaint.org/"
pkgdesc="An easy-to-use paint program"
license="BSD-2-Clauase AND LGPL-2.0-or-later AND GFDL-1.2"
makedepends="extra-cmake-modules qt5-qtbase-dev kdoctools-dev ki18n-dev kguiaddons-dev kwidgetsaddons-dev kio-dev kxmlgui-dev kiconthemes-dev ktextwidgets-dev kitemmodels-dev kdelibs4support-dev libksane-dev"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/kolourpaint-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -20,10 +27,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}