aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-03 10:26:31 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 08:59:04 +0000
commit8b256dcd696715633a9f885f8e8e8de0017d8f9a (patch)
tree4bdfdf05e288a23482471b6747af2dafbad0c362
parentfac66d15a3f70309f7f8efed142b0805d65a3c5e (diff)
downloadaports-8b256dcd696715633a9f885f8e8e8de0017d8f9a.tar.bz2
aports-8b256dcd696715633a9f885f8e8e8de0017d8f9a.tar.xz
community/domoticz: fix build without git installed
Let build continue when git is not found. No changes in behaviour because all attempts to use git (to get project revision etc) fail due to missing .git folder in the source tarball and project falls back to appversion.default in any case.
-rw-r--r--community/domoticz/APKBUILD6
-rw-r--r--community/domoticz/do-not-fail-if-git-missing.patch11
2 files changed, 15 insertions, 2 deletions
diff --git a/community/domoticz/APKBUILD b/community/domoticz/APKBUILD
index 59e209a5a3..7f0f4dd75c 100644
--- a/community/domoticz/APKBUILD
+++ b/community/domoticz/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=domoticz
pkgver=4.9700
-pkgrel=0
+pkgrel=1
pkgdesc="Open source Home Automation System"
url="http://www.domoticz.com/"
arch="all !armhf !armv7"
@@ -16,6 +16,7 @@ install="$pkgname.pre-install"
source="domoticz-$pkgver.tar.gz::https://github.com/domoticz/domoticz/archive/$pkgver.tar.gz
domoticz.confd
domoticz.initd
+ do-not-fail-if-git-missing.patch
"
builddir="$srcdir/domoticz-$pkgver"
@@ -67,4 +68,5 @@ package() {
sha512sums="f677a082b5ac4057142a6b71998d0e08042481821ceb2760a07af3745fc8900279e6b469e244fd3a08bb2dabf9efd903dd1e0c54adc726a09754594484bb92f6 domoticz-4.9700.tar.gz
724440da335f1e22c8dc181df62dac9ad2bcca98b39bff059de4be5901a93a0a8cb6864d92262092041d796ee7d3933f62cf337316d35a800bbb44f84a1709e0 domoticz.confd
-3ddbd3848cce2247a52e4673307a078717d75cb3fea2937d9f2442d94dccd0efc63120f1b0324c7091ae158cd0ec4fd36334af43bb887d45ff4a93e6a96e9bd2 domoticz.initd"
+3ddbd3848cce2247a52e4673307a078717d75cb3fea2937d9f2442d94dccd0efc63120f1b0324c7091ae158cd0ec4fd36334af43bb887d45ff4a93e6a96e9bd2 domoticz.initd
+dc3e9207b984b042866538f6fe87d02c0b182e41f3fc8d747ee5368f148614474733fe11971a928dc0673dafdb0857f88bfc03823c364e013d8fdb515dc24403 do-not-fail-if-git-missing.patch"
diff --git a/community/domoticz/do-not-fail-if-git-missing.patch b/community/domoticz/do-not-fail-if-git-missing.patch
new file mode 100644
index 0000000000..140cc6f6ce
--- /dev/null
+++ b/community/domoticz/do-not-fail-if-git-missing.patch
@@ -0,0 +1,11 @@
+--- a/getgit.cmake
++++ b/getgit.cmake
+@@ -4,7 +4,7 @@
+ # the git.cmake module is part of the standard distribution
+ find_package(Git)
+ if(NOT GIT_FOUND)
+- MESSAGE(FATAL_ERROR "Git not found!.")
++ MESSAGE(WARNING "Git not found!.")
+ endif()
+
+ MACRO(Gitversion_GET_REVISION dir variable)