aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-25 22:40:17 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-27 15:10:21 +0000
commit8c5b5674ae08c1a9b49687a5e86df1f1fc712281 (patch)
tree5db4893d567b1bf6fe6a0af6db083a6115896450
parent484cd1fdced387757bccd1166cebafb16964cefc (diff)
downloadaports-8c5b5674ae08c1a9b49687a5e86df1f1fc712281.tar.bz2
aports-8c5b5674ae08c1a9b49687a5e86df1f1fc712281.tar.xz
community/extra-cmake-modules: modernize, fix license, enable check
-rw-r--r--community/extra-cmake-modules/APKBUILD27
-rw-r--r--community/extra-cmake-modules/disable-KDEFetchTranslations.patch13
2 files changed, 28 insertions, 12 deletions
diff --git a/community/extra-cmake-modules/APKBUILD b/community/extra-cmake-modules/APKBUILD
index b88b67ccf9..aa2b940dcb 100644
--- a/community/extra-cmake-modules/APKBUILD
+++ b/community/extra-cmake-modules/APKBUILD
@@ -2,36 +2,39 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
pkgname=extra-cmake-modules
pkgver=5.58.0
-pkgrel=0
+pkgrel=1
pkgdesc="Extra CMake modules"
url="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
arch="noarch"
-license="custom"
+license="BSD-3-Clause"
depends="cmake"
-makedepends="py-sphinx cmake"
-options="!check" #check fails because of several packages missing
+makedepends="py-sphinx"
+checkdepends="qt5-qtbase-dev qt5-qtquickcontrols2-dev"
subpackages="$pkgname-doc"
-source="http://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="http://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ disable-KDEFetchTranslations.patch
+ "
prepare() {
default_prepare
- cd "$builddir"
mkdir -p build
}
build() {
cd "$builddir"/build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_TESTING=OFF
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_TESTING=ON
make
}
+check() {
+ cd "$builddir"/build
+ make test
+}
+
package() {
cd "$builddir"/build
make DESTDIR="$pkgdir" install/fast
-
- install -Dm644 ../COPYING-CMAKE-SCRIPTS \
- "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="edff7bcef7effad524743cf234ff6bb41ab59b7d8e4629ee11be9faea97985f32fff0d96cfaf25277acce9806abea3abe475c9dfe2f8c2dc1b61b7f52d2396bb extra-cmake-modules-5.58.0.tar.xz"
+sha512sums="edff7bcef7effad524743cf234ff6bb41ab59b7d8e4629ee11be9faea97985f32fff0d96cfaf25277acce9806abea3abe475c9dfe2f8c2dc1b61b7f52d2396bb extra-cmake-modules-5.58.0.tar.xz
+94f66c2977928d83499e69b326227c548401d0cba73dd70241f4745ba488571712081263da306fcd54b2abe935a6e9fb65ea3460994862e134fb37b51b2d5524 disable-KDEFetchTranslations.patch"
diff --git a/community/extra-cmake-modules/disable-KDEFetchTranslations.patch b/community/extra-cmake-modules/disable-KDEFetchTranslations.patch
new file mode 100644
index 0000000000..ab2c11b598
--- /dev/null
+++ b/community/extra-cmake-modules/disable-KDEFetchTranslations.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 9df03eb..040e184 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -111,7 +111,6 @@ endif()
+
+ add_test_macro(ExecuteCoreModules dummy)
+ add_test_macro(ExecuteKDEModules dummy)
+-add_test_macro(KDEFetchTranslations dummy)
+
+ add_test_macro(KDEInstallDirsTest.relative_or_absolute dummy)
+ add_test_variant(KDEInstallDirsTest.vars_in_sync_no_args
+