aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-05 23:19:58 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-13 03:27:58 -0300
commit8d1f6226c8c21b7a3e5165561ee659ae243b272c (patch)
tree46bf90cc390add8a5c32a2f8cab5cd7054a9401a
parent6db6558f9ae219d9be304f280896c84e08d06661 (diff)
downloadaports-8d1f6226c8c21b7a3e5165561ee659ae243b272c.tar.bz2
aports-8d1f6226c8c21b7a3e5165561ee659ae243b272c.tar.xz
testing/wgetpaste: new aport
-rw-r--r--testing/wgetpaste/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/wgetpaste/APKBUILD b/testing/wgetpaste/APKBUILD
new file mode 100644
index 0000000000..c68c479a0a
--- /dev/null
+++ b/testing/wgetpaste/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=wgetpaste
+pkgver=2.29
+pkgrel=0
+pkgdesc="Command-line interface to various pastebins"
+url="http://wgetpaste.zlin.dk/"
+arch="noarch"
+license="MIT"
+depends="wget"
+options="!check" # no tests
+subpackages="$pkgname-zsh-completion:zsh:noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zlin/wgetpaste/archive/${pkgver}.tar.gz"
+
+package() {
+ install -Dm755 wgetpaste "$pkgdir"/usr/bin/wgetpaste
+ install -Dm644 _wgetpaste "$pkgdir"/usr/share/zsh/site-functions/_wgetpaste
+}
+
+zsh() {
+ pkgdesc="Zsh completion for wgetpaste"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share/zsh/site-functions
+ mv "$pkgdir"/usr/share/zsh/site-functions/* \
+ "$subpkgdir"/usr/share/zsh/site-functions
+}
+sha512sums="02e4a80d16354d42472d1b2189efd0847cf592ae4bea08969b9aae12731983e172add8e3c0d4ab9df3306bdad0aa7603058ba0411be8ec61d122c7ebbd0611d7 wgetpaste-2.29.tar.gz"