aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-14 19:12:57 +0300
committerprspkt <prspkt@protonmail.com>2019-06-14 19:35:43 +0300
commit90ff66b311f7a55cb42a57410eab1c56c156a191 (patch)
tree2e5a89b07a89b9f9e43b7513efdc9e38e29bb6e2
parent3ab42e8f340a658b2ddcbfc754524f43036f7bb3 (diff)
downloadaports-90ff66b311f7a55cb42a57410eab1c56c156a191.tar.bz2
aports-90ff66b311f7a55cb42a57410eab1c56c156a191.tar.xz
testing/py3-pelican: clarify license, modernize
-rw-r--r--testing/py3-pelican/APKBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/testing/py3-pelican/APKBUILD b/testing/py3-pelican/APKBUILD
index 9ea32a4305..66b981a11f 100644
--- a/testing/py3-pelican/APKBUILD
+++ b/testing/py3-pelican/APKBUILD
@@ -4,25 +4,35 @@ pkgname=py3-pelican
_pkgname=pelican
pkgver=3.7.1
pkgrel=1
-pkgdesc="A tool to generate a static blog from reStructuredText or Markdown input files."
-url="https://pypi.python.org/pypi/pelican/"
+pkgdesc="Static site generator written in Python"
+url="https://getpelican.com"
arch="noarch"
-license="AGPL-3.0"
+license="AGPL-3.0-only"
depends="py3-blinker py3-dateutil py3-docutils py3-feedgenerator py3-jinja2
py3-pygments py3-setuptools py3-six py3-tz py3-unidecode"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ default_prepare
+
+ # remove shebang from python files
+ sed -i '1d' \
+ pelican/tools/*.py \
+ pelican/tools/templates/*.py.jinja2
+
+ # substitute feedgenerator with django feedgenerator
+ sed -i 's|feedgenerator|django.utils.feedgenerator|' pelican/writers.py
+}
+
replaces="pelican" # Backwards compatibility
provides="pelican=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}