aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2016-12-13 16:29:04 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-01-03 10:48:02 +0000
commit9221ae4c9fd957a4b3814c12f2dc25a7111c51a2 (patch)
tree6ea1805df8a2d33ab7df7bcdc26bb72b585b03eb
parent8c8f819f895a39f75161dacd31d9a286d25aaf64 (diff)
downloadaports-9221ae4c9fd957a4b3814c12f2dc25a7111c51a2.tar.bz2
aports-9221ae4c9fd957a4b3814c12f2dc25a7111c51a2.tar.xz
testing/uncrustify: new aport
https://github.com/uncrustify/uncrustify A source code beautifier
-rw-r--r--testing/uncrustify/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/uncrustify/APKBUILD b/testing/uncrustify/APKBUILD
new file mode 100644
index 0000000000..19fa6eec8a
--- /dev/null
+++ b/testing/uncrustify/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Andre Klitzing <aklitzing@gmail.com>
+
+pkgname=uncrustify
+pkgver=0.64
+pkgrel=0
+pkgdesc="A source code beautifier"
+url="https://github.com/uncrustify/uncrustify"
+arch="all"
+license="GPL2"
+makedepends="cmake"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"
+
+build() {
+ cd "$builddir"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -d -m755 "$pkgdir"/usr/share/$pkgname
+ install -m644 etc/*.cfg "$pkgdir"/usr/share/$pkgname
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+
+ cd build
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+md5sums="008904ca40d07c4b3d66c717d59cb65b uncrustify-0.64.tar.gz"
+sha256sums="0fca05fe8bac2cd80bf3ed77378c82ffe365f37a3f80b8e0ca2dbb3c6e25f3d7 uncrustify-0.64.tar.gz"
+sha512sums="27be7bceccab20d58ad8f7bb875f1270771f9c0994d6aac404743028ccb9002229d5f000d7cfb4264e66409581f7339b88e17e5ad9b8dd2e8817431268411a0f uncrustify-0.64.tar.gz"