aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-04-16 22:39:03 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-26 20:01:44 +0000
commit94028bb81f0f17f74fc1b456d44db18c5dddf947 (patch)
treed3a495b6e7c29d8e508c0d85c65e21301aa9af18
parent289a14ceb7e2737a780cfd969fcd97b232e66e21 (diff)
downloadaports-94028bb81f0f17f74fc1b456d44db18c5dddf947.tar.bz2
aports-94028bb81f0f17f74fc1b456d44db18c5dddf947.tar.xz
community/imagemagick6: enable on arches without librsvg
-rw-r--r--community/imagemagick6/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/community/imagemagick6/APKBUILD b/community/imagemagick6/APKBUILD
index ca9c35b3e2..1ce6a5c5b7 100644
--- a/community/imagemagick6/APKBUILD
+++ b/community/imagemagick6/APKBUILD
@@ -6,16 +6,23 @@ _pkgname=ImageMagick6
pkgver=6.9.11.6
_pkgver=${pkgver%.*}-${pkgver##*.}
_abiver=${pkgname#imagemagick}
-pkgrel=0
+pkgrel=1
pkgdesc="A collection of tools and libraries for many image formats (legacy version $_abiver)"
url="https://www.imagemagick.org/"
-arch="all !s390x !mips !mips64" # librsvg
+arch="all"
license="Apache-2.0"
options="libtool"
depends_dev="!${pkgname%$_abiver}-dev"
makedepends="fontconfig-dev freetype-dev ghostscript-dev lcms2-dev
- libjpeg-turbo-dev libpng-dev librsvg-dev libtool libxml2-dev tiff-dev
+ libjpeg-turbo-dev libpng-dev libtool libxml2-dev tiff-dev
zlib-dev"
+
+case "$CARCH" in
+ s390x) ;;
+ mips*) options="!check" ;;
+ *) makedepends="$makedepends librsvg-dev" ;;
+esac
+
checkdepends="freetype fontconfig ghostscript ghostscript-fonts lcms2 graphviz"
subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs"
source="$_pkgname-$_pkgver.tar.gz::https://github.com/ImageMagick/ImageMagick6/archive/$_pkgver.tar.gz"