aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-03-07 01:04:06 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-03-07 01:04:56 +0000
commit94b66949fdca3ae6db7a5e170db0ea17122f683e (patch)
tree2aa32304074ba8953453e764dd9a263b6869697f
parente676d445d440c9372fa44a0a5817853717063a00 (diff)
downloadaports-94b66949fdca3ae6db7a5e170db0ea17122f683e.tar.bz2
aports-94b66949fdca3ae6db7a5e170db0ea17122f683e.tar.xz
testing/aixlog: new aport
-rw-r--r--testing/aixlog/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/aixlog/APKBUILD b/testing/aixlog/APKBUILD
new file mode 100644
index 0000000000..065696fb2e
--- /dev/null
+++ b/testing/aixlog/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer:
+pkgname=aixlog
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Header-only C++ logging library"
+url="https://github.com/badaix/aixlog"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="cmake bash"
+install=""
+options="!check" # not test
+subpackages=""
+source="aixlog-$pkgver.tar.gz::https://github.com/badaix/aixlog/archive/v$pkgver.tar.gz"
+builddir="$srcdir/aixlog-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4fb4a7e4ab0a1a7ac005367b4935f34f8f5599c8f49db8e7696fd2759efdbd02606539e7b904c866d08fcd7ccb3666fb55c54ae5cb8ce890cf4297ca5993845e aixlog-1.1.0.tar.gz"