aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-09-10 16:50:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-11 06:58:58 +0000
commit9636165db6ed13255c4f775b63a9828e078a8afb (patch)
tree2000690e5fefe7f7fb7f1428f4fc2709a2090fce
parentfa439f4d0f80cc8a338395d5d2a1f0c6c46decb3 (diff)
downloadaports-9636165db6ed13255c4f775b63a9828e078a8afb.tar.bz2
aports-9636165db6ed13255c4f775b63a9828e078a8afb.tar.xz
community/icinga2: rebuild against boost 1.71
-rw-r--r--community/icinga2/APKBUILD4
-rw-r--r--community/icinga2/boost.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/community/icinga2/APKBUILD b/community/icinga2/APKBUILD
index b042f20b69..8c909158a1 100644
--- a/community/icinga2/APKBUILD
+++ b/community/icinga2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icinga2
pkgver=2.10.6
-pkgrel=0
+pkgrel=1
pkgdesc="An open source host, service and network monitoring program"
url="http://www.icinga.org"
arch="all !armhf !armv7"
@@ -15,6 +15,7 @@ pkgusers="icinga"
pkggroups="icinga icingacmd"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch $pkgname-vim::noarch $pkgname-openrc"
source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz
+ boost.patch
$pkgname.initd"
builddir="$srcdir/$pkgname-$pkgver"
@@ -120,4 +121,5 @@ vim() {
}
sha512sums="ab1440fdbb36217c5e50d8a254d0f1294e412325038fcc02496c606558ab33f4fafda93b1f439ab6e51e956aff6daddee005282b6d529c7e9d9d781af120834d icinga2-2.10.6.tar.gz
+2ecf1682c4be14ea68343dc6c8140a3a70aa279189d64d8fe1c588f9db971de8e599bdd2ae1c0675eee1eecc7a93fb89ac8ee73abaa0314f6c8384ef4fba1d0f boost.patch
46890756104563b1a4bc60b5952a2d63f5263883cfe702de7ccc4616dfe5b20d380ff1bc190482741a06bcfe7e662ad14a6965e26b9ce916ef56a1248d6b524c icinga2.initd"
diff --git a/community/icinga2/boost.patch b/community/icinga2/boost.patch
new file mode 100644
index 0000000000..0d8be6b7dd
--- /dev/null
+++ b/community/icinga2/boost.patch
@@ -0,0 +1,13 @@
+diff --git a/third-party/cmake/BoostTestTargets.cmake b/third-party/cmake/BoostTestTargets.cmake
+index 8c26324..e99515f 100644
+--- a/third-party/cmake/BoostTestTargets.cmake
++++ b/third-party/cmake/BoostTestTargets.cmake
+@@ -47,7 +47,7 @@ set(BOOST_TEST_TARGET_PREFIX "boosttest")
+ if(NOT Boost_FOUND)
+ find_package(Boost 1.34.0 QUIET)
+ endif()
+-if("${Boost_VERSION}0" LESS "1034000")
++if("${Boost_VERSION}0" LESS "1.34.0")
+ set(_shared_msg
+ "NOTE: boost::test-based targets and tests cannot "
+ "be added: boost >= 1.34.0 required but not found. "