aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Fontaine <antoine.fontaine@epfl.ch>2020-04-09 00:52:59 +0200
committerTBK <tbk@jjtc.eu>2020-04-13 15:40:34 +0000
commit99308c8d8a9a9ac826d02e5b3cf7ca3566dbdbdc (patch)
treeab054ec8beb7f4c16b8584fe928ba0683a064b5f
parent5ca3bed1a4283337c4d20a70b6f7c1026cba99c0 (diff)
downloadaports-99308c8d8a9a9ac826d02e5b3cf7ca3566dbdbdc.tar.bz2
aports-99308c8d8a9a9ac826d02e5b3cf7ca3566dbdbdc.tar.xz
testing/anbox: upgrade to 20200408, drop lxc dependency and fix init script
drop lxc dependency, as apk detects the lxc-libs dep and the init script creates the required directory itself. fix the init script: when the container manager failed, the openRC service wasn't able to start. It could not be started again because anbox-bridge.sh errored out: it was unable to create an already existing interface.
-rw-r--r--testing/anbox/APKBUILD11
-rw-r--r--testing/anbox/anbox-container-manager.initd17
2 files changed, 18 insertions, 10 deletions
diff --git a/testing/anbox/APKBUILD b/testing/anbox/APKBUILD
index 1d3923d272..10fbc8cfc8 100644
--- a/testing/anbox/APKBUILD
+++ b/testing/anbox/APKBUILD
@@ -3,9 +3,9 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
# Maintainer:
pkgname=anbox
-pkgver=0_git20200303
-pkgrel=3
-_commit="3ed2e6d5c360d57b6aa61386e279adf3ff155ded"
+pkgver=0_git20200408
+pkgrel=0
+_commit="6d9ada9d10348589a03d8101e7cb9f50d6d0b5fb"
_cpu_features_commit="b5c271c53759b2b15ff91df19bd0b32f2966e275"
pkgdesc="Android in a box"
url="https://github.com/anbox/anbox"
@@ -19,7 +19,6 @@ depends="
mesa-gles
mesa-egl
fuse3
- lxc
"
makedepends="
mesa-dev
@@ -110,9 +109,9 @@ package() {
"$pkgdir"/usr/share/anbox/anbox-shell.sh
}
-sha512sums="e75030e2c522c7561677a61d395fbbde4eb4fee316ccf803a12e338820091384a604198f1a05e6a8746fec766f9a9b06995fadd15917d835fc45010775a2d4e6 anbox-3ed2e6d5c360d57b6aa61386e279adf3ff155ded.tar.gz
+sha512sums="5fe3644358f84ba2253932ea4400f48ab48fdbe4655eeb006dd6f0cdf3f3e02f2d528974737cf27aa0248cc2ab87710dd5181371ce46fc9cc6c94c7b38b84590 anbox-6d9ada9d10348589a03d8101e7cb9f50d6d0b5fb.tar.gz
c0ec9b603cec2cc9049923e15ef50c85806bc0a0ffe57b63348631061aeddb73c1eca910b25696cf5eac2606aec3f86db29e8a01e01cf438bfee86edfe909e4a cpu_features-b5c271c53759b2b15ff91df19bd0b32f2966e275.tar.gz
-b591fa7dacf3ef2164c4ee699da9a882d514d21a7be3a3aadaf196158b28849fd294cb466c7c6ec6c511a96ae1a1607b39195b617fa8b8b73ad38b5f6c64a7bf anbox-container-manager.initd
+959058eb1c1e3eb0d1593695ee57fbc0cc567f260235e81d7b56da62b0b80fca9112d5f16a1e1c5c0e6223c8a1899f97f906c7cc763dc015e094aacded818a2f anbox-container-manager.initd
6a3bc88142c5287ec54d481a4788eceb7772d9974af950b5286ce63a49d05d9d49fce5ba1d02b4b1c9893896fd4ba218fd4d39b8e640bdd61ad196b5d5c9a021 anbox.confd
401669509e05eb586ad40fc9e8f4284b52183f06c60e87bf4e923be165a72f10263daf226db7fd610ef6ff25d09abd140ca2d59187e2d1b85a0bd6ae887dd944 musl-fixes.patch
bc7fc34cd2cfde57e674c8bce5b1f7fd297bd54ed32e16a7ac197fc36a23993ea468d5e0508fde9be4c1b72e04557b988b6b54e34cc2a52d96bbdf27af777ee7 input-chmod.patch
diff --git a/testing/anbox/anbox-container-manager.initd b/testing/anbox/anbox-container-manager.initd
index 079e2c9f3c..d692e05238 100644
--- a/testing/anbox/anbox-container-manager.initd
+++ b/testing/anbox/anbox-container-manager.initd
@@ -8,6 +8,7 @@ command_args="container-manager --daemon --privileged --data-path=/var/lib/anbox
depend() {
need localmount sysfs cgroups fuse
+ use net
after firewall
}
@@ -19,11 +20,19 @@ start_pre() {
modprobe loop
modprobe tun
- /usr/share/anbox/anbox-bridge.sh start
+ if ip link show anbox0 >/dev/null 2>&1; then
+ ewarn "anbox0 network interface already exists"
+ else
+ ebegin "Creating anbox0 network interface"
+ /usr/share/anbox/anbox-bridge.sh start
+ eend $?
+ fi
}
stop_post() {
- # ideally, we would stop it _after_ shutting down
- # the container manager.
- /usr/share/anbox/anbox-bridge.sh stop
+ if ip link show anbox0 >/dev/null 2>&1; then
+ ebegin "Removing anbox0 network interface"
+ /usr/share/anbox/anbox-bridge.sh stop
+ eend $?
+ fi
}