aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-31 08:45:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-31 08:46:38 +0000
commit99882bbebdf30f44c250518caa39d828dff96045 (patch)
treebc65116409a537420002044dc09d9c0688e4b579
parent0affe33dcd2b871de43750519c7304b8b84a56c0 (diff)
downloadaports-99882bbebdf30f44c250518caa39d828dff96045.tar.bz2
aports-99882bbebdf30f44c250518caa39d828dff96045.tar.xz
main/mbedtls1: renamed
rename for mbedtls-2.0 upgrade
-rw-r--r--main/mbedtls1/APKBUILD (renamed from main/mbedtls/APKBUILD)15
-rw-r--r--main/mbedtls1/programs.makefile.patch (renamed from main/mbedtls/programs.makefile.patch)0
2 files changed, 8 insertions, 7 deletions
diff --git a/main/mbedtls/APKBUILD b/main/mbedtls1/APKBUILD
index f57b87d602..0304a81ffe 100644
--- a/main/mbedtls/APKBUILD
+++ b/main/mbedtls1/APKBUILD
@@ -1,19 +1,20 @@
# Maintainer: Łukasz Jendrysik <scadu@yandex.com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
-pkgname=mbedtls
+pkgname=mbedtls1
pkgver=1.3.11
pkgrel=0
pkgdesc='Portable cryptographic and SSL/TLS library'
arch=all
url='https://tls.mbed.org/'
license='GPL2'
+replaces="mbedtls"
subpackages="$pkgname-dev $pkgname-utils"
-source="https://tls.mbed.org/download/$pkgname-$pkgver-gpl.tgz
+source="https://tls.mbed.org/download/mbedtls-$pkgver-gpl.tgz
programs.makefile.patch"
prepare() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/mbedtls-$pkgver
sed -i 's|//\(#define POLARSSL_THREADING_C\)|\1|' include/polarssl/config.h
sed -i 's|//\(#define POLARSSL_THREADING_PTHREAD\)|\1|' include/polarssl/config.h
@@ -22,17 +23,17 @@ prepare() {
}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/mbedtls-$pkgver
LDFLAGS="$LDFLAGS -I../include " make SHARED=1 no_test || return 1
}
check() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/mbedtls-$pkgver
make SHARED=1 check || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$srcdir"/mbedtls-$pkgver
make DESTDIR="$pkgdir/usr" install || return 1
}
@@ -41,7 +42,7 @@ utils() {
install -d "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
- install -Dm755 "$srcdir"/$pkgname-$pkgver/programs/x509/cert_write \
+ install -Dm755 "$srcdir"/mbedtls-$pkgver/programs/x509/cert_write \
"$subpkgdir"/usr/bin/mbedtls_cert_write
}
diff --git a/main/mbedtls/programs.makefile.patch b/main/mbedtls1/programs.makefile.patch
index 3aef5f57c5..3aef5f57c5 100644
--- a/main/mbedtls/programs.makefile.patch
+++ b/main/mbedtls1/programs.makefile.patch