aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-06 21:57:17 +0300
committerprspkt <prspkt@protonmail.com>2019-07-06 21:58:43 +0300
commit9d7710e019a4be9442d14eb7a9c6856cbb640df5 (patch)
tree2ea78c0bc83b119050d3d033ae7d582383e0160d
parent2e11f13313653b3ffaf549c72d244bb99947b287 (diff)
downloadaports-9d7710e019a4be9442d14eb7a9c6856cbb640df5.tar.bz2
aports-9d7710e019a4be9442d14eb7a9c6856cbb640df5.tar.xz
testing/py3-astral: modernize
* Add checkdepends and run test suite.
-rw-r--r--testing/py3-astral/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/testing/py3-astral/APKBUILD b/testing/py3-astral/APKBUILD
index 0deb3c94cd..5e3370a2ac 100644
--- a/testing/py3-astral/APKBUILD
+++ b/testing/py3-astral/APKBUILD
@@ -3,15 +3,14 @@
pkgname=py3-astral
_pkgname=astral
pkgver=1.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Calculations for the position of the sun and moon"
-url="https://pypi.python.org/pypi/astral/"
+url="https://pypi.python.org/pypi/astral"
arch="noarch"
license="Apache-2.0"
-# Disable tests for now because they require an API key
-options="!check"
depends="py3-requests py3-tz python3"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="$_pkgname-$pkgver.tar.gz::https://github.com/sffjunkie/astral/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -19,17 +18,15 @@ replaces=py-astral # Backwards compatibility
provides=py-astral=$pkgver-r$pkgrel # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- python3 setup.py build
+ # skip the webtest since we lack an API key
+ py.test-3 -v -m "not webtest"
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}