aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-06-12 20:26:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-12 20:28:15 +0000
commit9ea885dce2d11602a2102acd899bf2efa17b2f0b (patch)
tree4dbc4a5d14824427d73245a1894d53a784624d79
parent1eb25a288efb727d9ec39afcfea8ae0471dc88c2 (diff)
downloadaports-9ea885dce2d11602a2102acd899bf2efa17b2f0b.tar.bz2
aports-9ea885dce2d11602a2102acd899bf2efa17b2f0b.tar.xz
main/u-boot: fix update-u-boot for cubiboard
fixes #8980
-rw-r--r--main/u-boot/APKBUILD4
-rwxr-xr-xmain/u-boot/update-u-boot2
2 files changed, 3 insertions, 3 deletions
diff --git a/main/u-boot/APKBUILD b/main/u-boot/APKBUILD
index 4362f603f8..5fbb767432 100644
--- a/main/u-boot/APKBUILD
+++ b/main/u-boot/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=u-boot
pkgver=2018.05
-pkgrel=0
+pkgrel=1
pkgdesc="u-boot bootloader common files"
url="http://www.denx.de/wiki/U-Boot/"
arch="armhf aarch64"
@@ -105,4 +105,4 @@ done
sha512sums="218f71282c9d027b0faf210ce2d4d713779e0c61ea4a23f03d5dec0ca8836a3c26b46c5e258d583834f5b5a2f4663f98729ca4b0101a60f85457eb892f8370d2 u-boot-2018.05.tar.bz2
f8c9bb6e84d6f0620c976ac7ad5dd7ec7ff9dfdd4b1d03d2bf6653e7beccf80bdf2debfc92fb1f696dba92fb40287d3c45897e0078951451d0835cb61a5f16d1 README.txt
-c860f2cd6fe0ad9a462ac12a7df24b621ac53a07ada21a53791fd14f73c08619adb1f70a61507cc0b531c7beb1953ea8224b8dca5585a5d11b8df43d9ee0ac76 update-u-boot"
+b3b4fb70c4eea2034bae45c513bca7b738be7507b46d3f2d62b31c794cd238d492acf960c95078cb1c945520debd5d2762103df7cef0fc36acfe9ff9a94549fc update-u-boot"
diff --git a/main/u-boot/update-u-boot b/main/u-boot/update-u-boot
index f55dfd5e0b..b012b5fedf 100755
--- a/main/u-boot/update-u-boot
+++ b/main/u-boot/update-u-boot
@@ -108,7 +108,7 @@ wand)
;;
cubie|cubie2)
[ -e "$imagedir/Cubieboard${board#cubie}" ] || die "Cubieboard images not installed, apk add u-boot-cubieboard"
- $dryrun dd if=$imagedir/Cubieboard${board#cubie}/u-boot-sunxi-with-spl.bin of=/dev/sda bs=1024 seek=8 status=none
+ $dryrun dd if=$imagedir/Cubieboard${board#cubie}/u-boot-sunxi-with-spl.bin of=$device bs=1024 seek=8 status=none
;;
mx6cuboxi)
[ -e "$imagedir/mx6cuboxi" ] || die "iMX6 Cubox-i images not installed, apk add u-boot-cuboxi"