aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-21 09:32:22 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-21 09:33:15 +0100
commit9fee86ba8fc187ff9141d1ebbf59f684e938c4ae (patch)
treeab74dd45d65c6ffa5e430a5d9a357389b1c5a997
parent1cf84d8515583281242f8854bbb18ccf7682657c (diff)
downloadaports-9fee86ba8fc187ff9141d1ebbf59f684e938c4ae.tar.bz2
aports-9fee86ba8fc187ff9141d1ebbf59f684e938c4ae.tar.xz
testing/py3-pynvim: run tests with xvfb-run and fix license
-rw-r--r--testing/py3-pynvim/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/testing/py3-pynvim/APKBUILD b/testing/py3-pynvim/APKBUILD
index 14cad74cd6..63d2e55d05 100644
--- a/testing/py3-pynvim/APKBUILD
+++ b/testing/py3-pynvim/APKBUILD
@@ -3,14 +3,14 @@
pkgname="py3-pynvim"
_pyname="pynvim"
pkgver="0.4.0"
-pkgrel=0
+pkgrel=1
pkgdesc="python client and plugin host for Nvim"
url="https://github.com/neovim/pynvim"
arch="noarch"
-license="Apache"
+license="Apache-2.0"
depends="neovim python3 py3-msgpack py3-greenlet"
-makedepends="python3-dev"
-checkdepends="py3-pytest py3-pytest-runner"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-runner xvfb-run"
source="$_pyname-$pkgver.tar.gz::https://github.com/neovim/$_pyname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
@@ -19,7 +19,7 @@ build() {
}
check() {
- python3 setup.py test
+ xvfb-run python3 setup.py test
}
package() {