aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-07 18:48:41 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-07 18:53:51 +0200
commita2e20091f4923ef281c70f124be821f3b030969c (patch)
treeea6c8ce3a15b9d474c62a6e968338f21ce5b4cc6
parent00aa8af5c325ba10d8229e5dfeb5067d08a5abff (diff)
downloadaports-a2e20091f4923ef281c70f124be821f3b030969c.tar.bz2
aports-a2e20091f4923ef281c70f124be821f3b030969c.tar.xz
main/quagga-nhrp: fix a nht issue in nhrpd patch
-rw-r--r--main/quagga-nhrp/0005-nhrpd-implement-next-hop-resolution-protocol.patch15
-rw-r--r--main/quagga-nhrp/APKBUILD8
2 files changed, 13 insertions, 10 deletions
diff --git a/main/quagga-nhrp/0005-nhrpd-implement-next-hop-resolution-protocol.patch b/main/quagga-nhrp/0005-nhrpd-implement-next-hop-resolution-protocol.patch
index f2f7696175..2572b3d14f 100644
--- a/main/quagga-nhrp/0005-nhrpd-implement-next-hop-resolution-protocol.patch
+++ b/main/quagga-nhrp/0005-nhrpd-implement-next-hop-resolution-protocol.patch
@@ -1,4 +1,4 @@
-From a7ca28fd70cee2dda0ee34883cce901af2a1e4bf Mon Sep 17 00:00:00 2001
+From dcd3163ce78dedb1f4e7df7a4788bfcac4dd2c72 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
Date: Fri, 25 Dec 2015 10:32:11 +0200
Subject: [PATCH 5/5] nhrpd: implement next hop resolution protocol
@@ -46,9 +46,9 @@ README.nhrpd and README.kernel for more details.
vtysh/vtysh.c | 1 +
vtysh/vtysh.h | 5 +-
zebra/zebra_rib.c | 2 +
- zebra/zebra_rnh.c | 19 +-
+ zebra/zebra_rnh.c | 21 +-
zebra/zebra_vty.c | 2 +
- 44 files changed, 7776 insertions(+), 11 deletions(-)
+ 44 files changed, 7778 insertions(+), 11 deletions(-)
create mode 100644 nhrpd/Makefile.am
create mode 100644 nhrpd/README.kernel
create mode 100644 nhrpd/README.nhrpd
@@ -8218,10 +8218,10 @@ index abb9560..b03ccc2 100644
/* Look into the RN and queue it into one or more priority queues,
diff --git a/zebra/zebra_rnh.c b/zebra/zebra_rnh.c
-index 5762d3f..98ca6d0 100644
+index 5762d3f..859b6d7 100644
--- a/zebra/zebra_rnh.c
+++ b/zebra/zebra_rnh.c
-@@ -223,15 +223,24 @@ zebra_evaluate_rnh_table (vrf_id_t vrfid, int family)
+@@ -223,16 +223,27 @@ zebra_evaluate_rnh_table (vrf_id_t vrfid, int family)
{
if (CHECK_FLAG (rib->status, RIB_ENTRY_REMOVED))
continue;
@@ -8249,8 +8249,11 @@ index 5762d3f..98ca6d0 100644
- else
- break;
}
++ else
++ break;
}
}
+
diff --git a/zebra/zebra_vty.c b/zebra/zebra_vty.c
index 38f61e9..c73896b 100644
--- a/zebra/zebra_vty.c
@@ -8272,5 +8275,5 @@ index 38f61e9..c73896b 100644
{
time_t uptime;
--
-2.10.1
+2.10.2
diff --git a/main/quagga-nhrp/APKBUILD b/main/quagga-nhrp/APKBUILD
index 59cf47cb1c..d7ccac4689 100644
--- a/main/quagga-nhrp/APKBUILD
+++ b/main/quagga-nhrp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=quagga-nhrp
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A free routing daemon replacing Zebra supporting RIP, OSPF, BGP and NHRP."
url="http://quagga.net/"
arch="all"
@@ -82,7 +82,7 @@ md5sums="daa303871e07ea5856aae6fd79e89722 quagga-1.1.0.tar.gz
6769244333af49b9a47268111ee690b6 0002-zebra-fix-nht-validity-checking-to-be-same-as-when-i.patch
78450d646cb3e63899a2223ab2dbce97 0003-bgpd-honor-disable-connected-check-option-with-next-.patch
f8c2e263994a9ca1705127f967d858f0 0004-bgpd-simplify-ebgp-multihop-and-ttl-security-handlin.patch
-b4d5c743d457b66ea284db8eb7ff4762 0005-nhrpd-implement-next-hop-resolution-protocol.patch
+92e66d8bf3058e1db660b89ca4fa323f 0005-nhrpd-implement-next-hop-resolution-protocol.patch
e1a27c077e323e3f915d4c3b142ca56b 0006-bgpd-allow-using-ebgp-multihop-for-ibgp-connections.patch
09a77e2e84e71c43f5a449738c026261 bgpd.initd
916f1dd1a286ee7b862cda4fe56cbf21 zebra.initd
@@ -93,7 +93,7 @@ a9cfc74247612640129a0bd8402e78380e35ce86f54ca4aeb40bfcf2a05c5688 0001-zebra-use
d290a449084d5be89b124b721a539772ab95e56304d0441723a8811fbd5fa692 0002-zebra-fix-nht-validity-checking-to-be-same-as-when-i.patch
463087091c5fe4ddcc85e476ac56d3bef8c964050b2a45c7b10e670d0c20911b 0003-bgpd-honor-disable-connected-check-option-with-next-.patch
643688c2b3f05b1b307821d0bad18f1452ccebf00d2a5b262ee6fe14f363b14b 0004-bgpd-simplify-ebgp-multihop-and-ttl-security-handlin.patch
-6669ebf4398c45c63e97c2caf2b9c76aaeaa29ca88df99835a5bab4dba5a5b52 0005-nhrpd-implement-next-hop-resolution-protocol.patch
+f7161e557fde61ce61094df564fe48900af390f2e6098b359d45ef4b0f460697 0005-nhrpd-implement-next-hop-resolution-protocol.patch
4ad0e70d235981c8063395b947a7a677a8d354b130fcf9eb545297e99ce96ddb 0006-bgpd-allow-using-ebgp-multihop-for-ibgp-connections.patch
aab037454c6a70cd5cb45e14c47b7dfea358f8d81c7d12418edcf7e58a86c679 bgpd.initd
c1d7526581927e990e687cbd5d08447eb060f76a439475572785b5b90c60c460 zebra.initd
@@ -104,7 +104,7 @@ sha512sums="3b29a90c4f05593714bda3c702fd2c8886ce48fba2fbfb98f55cc04d1025edd54279
4fb238f07b67d927fc1e5ec5cd184fb7a4247dfcb2e2733496db3277da439d2eb9728c634c40cd87a250b890170120f9b613aeb17aaaf054952d2e7ead81e63c 0002-zebra-fix-nht-validity-checking-to-be-same-as-when-i.patch
568c0c9ca2fff36c7ddf52908b8df7028b0f4242ae0329f002460ee632bb4d8067f5e2d3c1dbb5e1fcb513fe30674babf16338b923628ccc2f838b5c23f4fb39 0003-bgpd-honor-disable-connected-check-option-with-next-.patch
de0d14ceb91d6d858b790c276a2bced579696c36c954084892f90d6c36a27bec62cb496b18e11017fad5a1d646149130bf3bcada1f786f2a9939b606491eff15 0004-bgpd-simplify-ebgp-multihop-and-ttl-security-handlin.patch
-f731ea78847ce7eca459ebdeb57787380d369f095a3aff4d40aa95da017854f696b8a6e9820371e24948240580d5d691339d79fbb86007c8ea253dabf6eb1036 0005-nhrpd-implement-next-hop-resolution-protocol.patch
+9b58fc2be9757676f8ee9c7d766c98b58123f28cace08a3ff0eb7b237d7879c51a8324c8687f488597109fc4e2f30002ac9c1cb0a825bb2604f6723abbeddef6 0005-nhrpd-implement-next-hop-resolution-protocol.patch
dfa33341119fe51caa7bc33b44256f57361f2e3f8192862cca215b312ceb68e6a8c264dbf2a43d6244e6152bfad110cb0fdbefb065d95dd50389cf613d9720b3 0006-bgpd-allow-using-ebgp-multihop-for-ibgp-connections.patch
13b5b57e10df013bd2d931abc49bf76b8c4dee59dbceab22c9f151ccb988b2c5f7167f2909027d5e0f990b59da8de115667b02484aee9a67d347625700f6cacd bgpd.initd
1638a4a64ffd066b1884f7e5a4243edab68739aabd83bd35ea8c9608af7b8623eece1d59fb08feead84e4386b6d1da4220764ccf5fd7f2a9959a8470d5cce86a zebra.initd