aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreno <breno.leitao@gmail.com>2017-04-05 14:44:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-14 11:36:11 +0000
commita358f34ab30789c7c08de9a10ad2eac5e300051d (patch)
tree22295f56140ea71135115ce3ef65b0b51fbf7abe
parent00b936fa46df92ae20f5d130217a0ad5487b2c92 (diff)
downloadaports-a358f34ab30789c7c08de9a10ad2eac5e300051d.tar.bz2
aports-a358f34ab30789c7c08de9a10ad2eac5e300051d.tar.xz
testing/ed: New aport
GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands. Ed is the "standard" text editor in the sense that it is the original editor for Unix, and thus widely available. For most purposes, however, it is superseded by full-screen editors such as GNU Emacs or GNU Moe. This aport depends on an abuild change to understands .tar.lz files.
-rw-r--r--testing/ed/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/ed/APKBUILD b/testing/ed/APKBUILD
new file mode 100644
index 0000000000..7079ef1167
--- /dev/null
+++ b/testing/ed/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=ed
+pkgver=1.14.2
+pkgrel=0
+pkgdesc="GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files"
+url="https://www.gnu.org/software/ed/"
+arch="all"
+license="GPL"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.lz"
+
+builddir=$srcdir/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make all
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="653bcb89788b2d18c726336fb6f17678ac031fe6ea03a93ff248886a075c867ba5423d5471401e44cbdcce3b4cb766b621ca7b70d76881f5044ec3412767b11f ed-1.14.2.tar.lz"