aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-01-21 21:01:00 +0100
committerMilan P. Stanić <mps@arvanta.net>2020-01-21 21:02:13 +0100
commita8d7a02b326982829385a184c2b54dcfb18e62a4 (patch)
tree5a9cabb7f9ed7b605873010ad390a4d79dc751e4
parentbabd636c5739bb665950f9bb52242b14a778e593 (diff)
downloadaports-a8d7a02b326982829385a184c2b54dcfb18e62a4.tar.bz2
aports-a8d7a02b326982829385a184c2b54dcfb18e62a4.tar.xz
testing/setserial: new aport
http://setserial.sourceforge.net/ tool for change various attributes of a serial device
-rw-r--r--testing/setserial/APKBUILD32
-rw-r--r--testing/setserial/ioctls.patch14
-rw-r--r--testing/setserial/setserial.patch28
3 files changed, 74 insertions, 0 deletions
diff --git a/testing/setserial/APKBUILD b/testing/setserial/APKBUILD
new file mode 100644
index 0000000000..5b10cd70ab
--- /dev/null
+++ b/testing/setserial/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname="setserial"
+pkgver=2.17
+pkgrel=0
+pkgdesc="tool for change various attributes of a serial device"
+url="http://setserial.sourceforge.net/"
+arch="all"
+license="GPL-2.0-only"
+makedepends="groff"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/setserial/setserial-$pkgver.tar.gz
+ ioctls.patch
+ setserial.patch"
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --bindir=/bin
+ make
+}
+
+package() {
+ install -d $pkgdir/bin
+ install -d $pkgdir/usr/share/man/man8
+ make DESTDIR=$pkgdir install
+}
+
+sha512sums="27b4918d303302dfdbca2f8c4fe500685068cfbf3de70b4907bac5a9cdb2e643656c1d821e714c08723abcfbaf99129866002117450bef731a0a09cd38138645 setserial-2.17.tar.gz
+17e4ec065d5f51c80f3358c749b7c6b0257b380f4b81cb9af14312202098b045a0ea833e88a663d3b090f19a09430ee7c96e7046b794166263617cb859b1b3d9 ioctls.patch
+4c5f5bddb3f66aac51c1550d85726930221e995dd695f628bec37cf2f05c1db0c7b1c59ba745c32a9d8a91374a4491479f7786a58cfd0096157b2b22c764ac7f setserial.patch"
diff --git a/testing/setserial/ioctls.patch b/testing/setserial/ioctls.patch
new file mode 100644
index 0000000000..36d16afd14
--- /dev/null
+++ b/testing/setserial/ioctls.patch
@@ -0,0 +1,14 @@
+--- a/setserial.c 2000-01-27 16:40:52.000000000 +0100
++++ b/setserial.c 2014-03-26 18:53:04.720749160 +0100
+@@ -15,10 +15,8 @@
+ #include <termios.h>
+ #include <string.h>
+ #include <errno.h>
+-
+-#ifdef HAVE_ASM_IOCTLS_H
+ #include <asm/ioctls.h>
+-#endif
++
+ #ifdef HAVE_LINUX_HAYESESP_H
+ #include <linux/hayesesp.h>
+ #endif
diff --git a/testing/setserial/setserial.patch b/testing/setserial/setserial.patch
new file mode 100644
index 0000000000..3cce1f07d3
--- /dev/null
+++ b/testing/setserial/setserial.patch
@@ -0,0 +1,28 @@
+diff -ur setserial-2.17/Makefile.in setserial-2.17-new/Makefile.in
+--- setserial-2.17/Makefile.in 2000-01-27 16:39:07.000000000 +0100
++++ setserial-2.17-new/Makefile.in 2005-03-09 20:53:31.000000000 +0100
+@@ -17,6 +17,11 @@
+ INCS = -I.
+ TAR = tar
+
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++bindir=@bindir@
++mandir=@mandir@
++
+ all: setserial setserial.cat
+
+ setserial: setserial.c
+@@ -26,9 +31,9 @@
+ nroff -man setserial.8 > setserial.cat
+
+ install: setserial setserial.8
+- $(INSTALL_PROGRAM) setserial $(DESTDIR)/bin
+- $(STRIP) $(DESTDIR)/bin/setserial
+- $(INSTALL_DATA) setserial.8 $(DESTDIR)/usr/man/man8
++ $(INSTALL_PROGRAM) setserial $(DESTDIR)$(bindir)
++ $(STRIP) $(DESTDIR)$(bindir)/setserial
++ $(INSTALL_DATA) setserial.8 $(DESTDIR)$(mandir)/man8
+
+ clean:
+ $(RM) setserial setserial.o setserial.cat *~