aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-03-25 08:24:25 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-03-25 08:24:25 +0000
commita924aa20210e7f26602f9ecb3822fb78a101e251 (patch)
tree01ac3090d29bd7e6224ebe97143308c3dd308833
parent13863cc1f5f194a380e822e4dd6a6f548864f6b0 (diff)
downloadaports-a924aa20210e7f26602f9ecb3822fb78a101e251.tar.bz2
aports-a924aa20210e7f26602f9ecb3822fb78a101e251.tar.xz
testing/php7: fix sha256/512 passwords
ref #5141
-rw-r--r--testing/php7/APKBUILD8
-rw-r--r--testing/php7/fix-crypt.patch22
2 files changed, 6 insertions, 24 deletions
diff --git a/testing/php7/APKBUILD b/testing/php7/APKBUILD
index 7647cb1907..0e2115b4a0 100644
--- a/testing/php7/APKBUILD
+++ b/testing/php7/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php7
_pkgreal=php
pkgver=7.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="The PHP language runtime engine - 7th branch"
url="http://www.php.net/"
arch="x86_64 armhf"
@@ -408,7 +408,7 @@ a340f27e83ed4482d2fbb98658ef71cb php7-fpm.initd
66f0037a029f9eed2b31d2e1d50f1860 tidy-buffio.patch
d872e633c9b33c3c9f629dd2edd2e5c5 includedir.patch
6ba762ab7a105163b8e5b3913deae109 pid_log.patch
-fb689bad4206238a4b2afb5b8c49f079 fix-crypt.patch"
+7f12fabdd1494e1c994cadd167e401d8 fix-crypt.patch"
sha256sums="a246c503709c189ba8e1e22ed2cb22abc27da43a997ff1b3318e181baf529dcc php-7.0.4.tar.bz2
eca59e8b0498c1c93b35f9a5109ae56d0cda9d94822727d689371ccad31b3615 php7-fpm.initd
6e4406f21b69085714cdb9d9a67c08e27a1c737ab353f9813cb2fc268352d2c6 php7-fpm.logrotate
@@ -417,7 +417,7 @@ f739ca427a1dd53a388bad0823565299c5d4a5796b1171b892884e4d7d099bab install-pear.p
5dc8f32e5e2b1cd6317ada5a5adb9b5f0802ed6e0dbe065d7bfcc0f55d47e0d5 tidy-buffio.patch
ea74966a23b1b54548ee35e9ccc2fc8d2b7c2285c385c44d6b23d9e2f25ea1a7 includedir.patch
0cca8729c64682387a8c44ed74f0966da697f2817152d8d05bb25bedc7eaafec pid_log.patch
-38b37048042cad962b15767d2923437733a1fe3ef5d457b16e080ddfc206891c fix-crypt.patch"
+ffc10d325be398a5560fe9265e89f056ef2eba27981c98300be30bbc2f18a4ec fix-crypt.patch"
sha512sums="9d1dc761cdd9103a91299e01117c1790550e3b94e7694dcc2555d83e5abe3d2170acd6226e8501c5f2a77b5c374b1c9f5ea009999d476818c2682a54def86b96 php-7.0.4.tar.bz2
89076ab8e170a8f886b88bb30aa3e6a6b4463155a18ea53485cc9e3898c81afa3d01fb8403d28a45dc1680f09c645c2d81d8272bc8b9c7ced41e59b0ba226216 php7-fpm.initd
cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691 php7-fpm.logrotate
@@ -426,4 +426,4 @@ f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c93976
6894c9cba7752a3406e774d9efc0e058c37433493c1c20101e9563bf247c112157a67e306b06b9517b0422eca521f543d637a6cbd2cea7639e43f13d773b3d2b tidy-buffio.patch
199aecdbd3b4035aabf5379c215f82412d3c98b79a1ee186944e7fe1f0ed6f40789ea30e2355149491de6be34fc66c5e486e2a79a7e41ab2ae18706ef3ffe79b includedir.patch
82231c7b27b4d044272857dc713674884715ed8e36e54be06faa5d2a949ba4bca597628958a9c5683ec51c36e05a00f6be811c7e95112b0314c98528f584a8d6 pid_log.patch
-b43336e394f601e0350b78cc0de12fe16a494c70b2982f6f3d49154a189962cdc2da86a1ee1ea23a0bb3ce3655e27840ad3d01beff548adfd20fd89e87fc6349 fix-crypt.patch"
+b4badb1850bf99210498d6e27136ee275379b5c39c52904b292aed204d5c95a845ed53db7dd56856121b3019ffefc7632419f9b2c45f431165ec0b5c5cbe974d fix-crypt.patch"
diff --git a/testing/php7/fix-crypt.patch b/testing/php7/fix-crypt.patch
index f21ee4d5fe..8f0d919378 100644
--- a/testing/php7/fix-crypt.patch
+++ b/testing/php7/fix-crypt.patch
@@ -1,23 +1,5 @@
---- php-7.0.4.orig/ext/standard/config.m4
-+++ php-7.0.4/ext/standard/config.m4
-@@ -314,7 +314,7 @@
- fi
- AC_DEFINE_UNQUOTED(PHP_MD5_CRYPT, $ac_result, [Whether the system supports MD5 salt])
-
-- if test "$ac_cv_crypt_sha512" = "yes"; then
-+ if test "$ac_cv_crypt_SHA512" = "yes"; then
- ac_result=1
- ac_crypt_sha512=1
- else
-@@ -323,7 +323,7 @@
- fi
- AC_DEFINE_UNQUOTED(PHP_SHA512_CRYPT, $ac_result, [Whether the system supports SHA512 salt])
-
-- if test "$ac_cv_crypt_sha256" = "yes"; then
-+ if test "$ac_cv_crypt_SHA256" = "yes"; then
- ac_result=1
- ac_crypt_sha256=1
- else
+https://bugs.php.net/bug.php?id=67512
+
--- php-7.0.4.orig/ext/standard/crypt.c
+++ php-7.0.4/ext/standard/crypt.c
@@ -58,6 +58,7 @@