aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-03-05 13:02:12 -0600
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-01 19:11:31 +0000
commita9bccb09bad16864922406dbe9286e05f7402574 (patch)
treeff4ad108bed2319ab0868d1b1ce047a25e0f5c9e
parent0ebd74570127c670bfb45dab635c544dac4d5748 (diff)
downloadaports-a9bccb09bad16864922406dbe9286e05f7402574.tar.bz2
aports-a9bccb09bad16864922406dbe9286e05f7402574.tar.xz
testing/gx-go: new aport
https://github.com/whyrusleeping/gx-go A tool to use with the gx package manager for packages written in go
-rw-r--r--testing/gx-go/APKBUILD57
-rw-r--r--testing/gx-go/glide.lock86
-rw-r--r--testing/gx-go/glide.yaml12
3 files changed, 155 insertions, 0 deletions
diff --git a/testing/gx-go/APKBUILD b/testing/gx-go/APKBUILD
new file mode 100644
index 0000000000..236212e657
--- /dev/null
+++ b/testing/gx-go/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=gx-go
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="A tool to use with the gx package manager for packages written in go"
+url="https://github.com/whyrusleeping/gx-go"
+arch="all"
+license="MIT"
+options="!check" # Test suite issues
+makedepends="git glide go"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/whyrusleeping/$pkgname/archive/v$pkgver.tar.gz
+ glide.yaml
+ glide.lock
+ "
+builddir="$srcdir/src/github.com/whyrusleeping/$pkgname"
+
+prepare() {
+ export GOPATH="$srcdir"
+
+ mkdir -p $(dirname $builddir)
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+
+ cd "$builddir"
+ cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
+ glide install --skip-test
+
+ default_prepare
+}
+
+build() {
+ GOPATH="$srcdir" GOBIN="$GOPATH/bin" make
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm 755 bin/gx-go "$pkgdir/usr/bin/gx-go"
+
+ cd "$builddir"
+ install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+}
+
+glide_init() {
+ abuild clean deps unpack prepare
+ cd "$builddir"
+ export GOPATH="$startdir"
+ rm -f glide.yaml glide.lock
+ glide init --non-interactive
+ glide update
+ cp glide.yaml glide.lock "$startdir"
+ cd "$startdir" && abuild checksum clean
+}
+
+sha512sums="3df8a99d257098afdf99ba6cbf58d50eab196f823ae53db48865a4f4962e38b84a66ffc99d5a342b43ff9891c8245252a77677b75c770d86f93ef1ad3c9e879f gx-go-1.9.0.tar.gz
+db824fce3e8094e2806c68b18ba5b8decae4cb62068113f6bc97f72de1224bd326b3342297739ee9b5a86bd4f7c9ec2f9b04aa3610cc95903dc1b3bfd7b0934f glide.yaml
+0a13f10b02099f2c60a8d1bbc83faf4552ae04358b4df99d431712704004030f3af31142ea81ed5f038e51ef6aeeeb3cf1946fd90e9d164af0d551ce0a0425d9 glide.lock"
diff --git a/testing/gx-go/glide.lock b/testing/gx-go/glide.lock
new file mode 100644
index 0000000000..12c33b836d
--- /dev/null
+++ b/testing/gx-go/glide.lock
@@ -0,0 +1,86 @@
+hash: 95215163a517cde934cd6d76708d61d7593e3d0f75f09c30dab341e8462c4d8a
+updated: 2019-04-01T09:33:13.761921059-06:00
+imports:
+- name: github.com/btcsuite/btcd
+ version: aa6e0f35703c1438cc45860ddc0c3f6e6c633c93
+ subpackages:
+ - btcec
+- name: github.com/gogo/protobuf
+ version: 382325bbbb4d1c850eec1f3ec92a1a16f502d68b
+ subpackages:
+ - proto
+- name: github.com/gxed/hashland
+ version: a72cc0875a1e95edd309d3134bc7c11bf2d7360b
+ subpackages:
+ - keccakpg
+ - murmur3
+- name: github.com/ipfs/go-ipfs-api
+ version: 26337195b3df044934572dc3ca9ccb175ce057b2
+ subpackages:
+ - options
+- name: github.com/ipfs/go-ipfs-files
+ version: c68472a9b1ec45177ccf8fda607698c86ae0060f
+- name: github.com/kr/fs
+ version: 1455def202f6e05b95cc7bfc7e8ae67ae5141eba
+- name: github.com/libp2p/go-flow-metrics
+ version: 5b4a5750cdd34754b1a417b4c7c7d1c24790b4d4
+- name: github.com/libp2p/go-libp2p-crypto
+ version: b0ed0e663e8b6832bad3f4502b2f6551ff2686cd
+ subpackages:
+ - pb
+- name: github.com/libp2p/go-libp2p-metrics
+ version: a64ed6c7351276b3f21cbfa033ceba9bd096c3af
+- name: github.com/libp2p/go-libp2p-peer
+ version: 96d6d7940e6fc555240a92d1b4615049cd451da2
+- name: github.com/libp2p/go-libp2p-protocol
+ version: 89147e29c7ab3b76c6f8be5b6fcdf3839aec286f
+- name: github.com/minio/blake2b-simd
+ version: 3f5f724cb5b182a5c278d6d3d55b40e7f8c2efb4
+- name: github.com/minio/sha256-simd
+ version: 3557f3d43a123835ffa5846e4d055146e773d52e
+- name: github.com/mitchellh/go-homedir
+ version: af06845cf3004701891bf4fdb884bfe4920b3727
+- name: github.com/mr-tron/base58
+ version: 6598572f05537592acb5a609ff53c4c7fbba7a3e
+ subpackages:
+ - base58
+- name: github.com/multiformats/go-multiaddr
+ version: ce21123d5172669bbf37a166078bc5f9d345ec2f
+- name: github.com/multiformats/go-multiaddr-dns
+ version: 7d0de25ce05c9294aa44f320c03c7e85e11bbb0b
+- name: github.com/multiformats/go-multiaddr-net
+ version: bd61b0499a3cfc893a8eb109c5669342b1671881
+- name: github.com/multiformats/go-multihash
+ version: 2ca70e715b6950a9382097b770a3f44fd570d388
+- name: github.com/sabhiram/go-gitignore
+ version: d3107576ba9425fc1c85f4b3569c4631b805a02e
+- name: github.com/urfave/cli
+ version: 693af58b4d51b8fcc7f9d89576da170765980581
+- name: github.com/whyrusleeping/gx
+ version: ca314b1e9e6be0432e50a30737c0e0720e67dd0f
+ subpackages:
+ - gxutil
+- name: github.com/whyrusleeping/gx-go
+ version: d92567959e16cc58afd1edc83db02be880f495e9
+ subpackages:
+ - rewrite
+- name: github.com/whyrusleeping/progmeter
+ version: f3e57218a75b913eff88d49a52c1debf9684ea04
+- name: github.com/whyrusleeping/stump
+ version: 206f8f13aae1697a6fc1f4a55799faf955971fc5
+- name: github.com/whyrusleeping/tar-utils
+ version: 8c6c8ba81d5c71fd69c0f48dbde4b2fb422b6dfc
+- name: golang.org/x/crypto
+ version: a5d413f7728c81fb97d96a2b722368945f651e78
+ subpackages:
+ - blake2s
+ - ed25519
+ - ed25519/internal/edwards25519
+ - sha3
+- name: golang.org/x/sys
+ version: f49334f85ddcf0f08d7fb6dd7363e9e6d6b777eb
+ subpackages:
+ - cpu
+ - unix
+ - windows
+testImports: []
diff --git a/testing/gx-go/glide.yaml b/testing/gx-go/glide.yaml
new file mode 100644
index 0000000000..b5214da724
--- /dev/null
+++ b/testing/gx-go/glide.yaml
@@ -0,0 +1,12 @@
+package: src/github.com/whyrusleeping/gx-go
+import:
+- package: github.com/kr/fs
+- package: github.com/mitchellh/go-homedir
+- package: github.com/urfave/cli
+- package: github.com/whyrusleeping/gx-go
+ subpackages:
+ - rewrite
+- package: github.com/whyrusleeping/gx
+ subpackages:
+ - gxutil
+- package: github.com/whyrusleeping/stump