aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 07:11:27 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 10:11:13 -0300
commita9c27d515d116c3887231a990ea6dca3e207a7b0 (patch)
tree41875bc797ef8fce9acc0250a3d92e52ff29cf35
parentd63e0479bafb534444d711e8d8891ef173677fed (diff)
downloadaports-a9c27d515d116c3887231a990ea6dca3e207a7b0.tar.bz2
aports-a9c27d515d116c3887231a990ea6dca3e207a7b0.tar.xz
community/py3-decorator: drop py2
-rw-r--r--community/py3-decorator/APKBUILD48
1 files changed, 13 insertions, 35 deletions
diff --git a/community/py3-decorator/APKBUILD b/community/py3-decorator/APKBUILD
index 4af1e73113..c1e9ac45ed 100644
--- a/community/py3-decorator/APKBUILD
+++ b/community/py3-decorator/APKBUILD
@@ -1,53 +1,31 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-decorator
+pkgname=py3-decorator
_pkgname=decorator
pkgver=4.4.0
-pkgrel=1
-pkgdesc="Python Decorator module"
-url="https://pypi.python.org/pypi/decorator"
+pkgrel=2
+pkgdesc="Python3 Decorator module"
+options="!check" # No checks on PYPI, github tarball is outdated (4.3.2)
+url="https://github.com/micheles/decorator"
arch="noarch"
license="BSD-2-Clause"
-depends=""
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-check() {
- cd "$builddir"
- python2 setup.py check
- python3 setup.py check
-}
-
+replaces="py-decorator" # Backwards compatibility
+provides="py-decorator=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
+check() {
+ python3 setup.py check
}
-_py3() {
- _py python3
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-
sha512sums="32c35c80581cb7fd0b2461d21c7eb14190294b2ccc9f92749b6bc74449f7d02a26281e9a2817f6f16871a6cddb7b02b8fae8119c22256fe43a6aaa31a7599dd5 decorator-4.4.0.tar.gz"