aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Lacerda <alancordeiro@gmail.com>2014-12-15 14:42:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-12-16 15:46:49 +0000
commita9e59d52bb2fce068924495b6a9d831f30555447 (patch)
treeeae16319ed78fa33d7fb4108e25b48acca25d39b
parent7cdb47dbcbe4ce510b8c0c474385362bb6c390f0 (diff)
downloadaports-a9e59d52bb2fce068924495b6a9d831f30555447.tar.bz2
aports-a9e59d52bb2fce068924495b6a9d831f30555447.tar.xz
testing/mate-common: new aport
-rw-r--r--testing/mate-common/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/mate-common/APKBUILD b/testing/mate-common/APKBUILD
new file mode 100644
index 0000000000..f6895daaa8
--- /dev/null
+++ b/testing/mate-common/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer:
+pkgname=mate-common
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="Common scripts and macros"
+url="http://mate-desktop.org/"
+arch="noarch"
+license="CC"
+depends=""
+depends_dev=""
+makedepends="autoconf automake gettext"
+install=""
+subpackages=""
+source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="bada705720debdb00f0b6b18e03ce5af mate-common-1.9.0.tar.xz"
+sha256sums="75fc61199308757b2b4c4f9f55a4198eeda3acb07fb7397083b12a21764f5338 mate-common-1.9.0.tar.xz"
+sha512sums="8fe26770331650bdb1fd1eb96c5a1a320eaa9bcc9de22ec4e6dc4fd766365a6ed02f0de08399e191d6c5572ad4a3fc9d258fcc691262235540bcec75ff51b4df mate-common-1.9.0.tar.xz"