aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdriaan Groenenboom <agboom@pm.me>2019-11-27 06:30:55 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-11-27 14:01:45 +0100
commitad2c95988babb7e4e20dc99c99586a3fd0ab7c7d (patch)
treebb40c6d3abb9d99db56f44717e2f63ae84664504
parent084c083ad2f962b2943a653ca85a73c75bdca367 (diff)
downloadaports-ad2c95988babb7e4e20dc99c99586a3fd0ab7c7d.tar.bz2
aports-ad2c95988babb7e4e20dc99c99586a3fd0ab7c7d.tar.xz
testing/dlib: new aport
http://dlib.net A toolkit for making real world machine learning and data analysis applications in C++
-rw-r--r--testing/dlib/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/dlib/APKBUILD b/testing/dlib/APKBUILD
new file mode 100644
index 0000000000..e97aec025a
--- /dev/null
+++ b/testing/dlib/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Davis E. King <davis@dlib.net>
+# Maintainer: Adriaan Groenenboom <agboom@pm.me>
+pkgname=dlib
+pkgver=19.18
+pkgrel=0
+pkgdesc="A toolkit for making real world machine learning and data analysis applications in C++"
+url="http://dlib.net"
+arch="all"
+license="BSL-1.0"
+makedepends="cmake openblas-dev libx11-dev pkgconf libjpeg-turbo-dev libpng-dev"
+source="dlib-$pkgver.tar.bz2::https://downloads.sourceforge.net/project/dclib/dlib/v$pkgver/dlib-$pkgver.tar.bz2"
+sha512sums="0b65c35b6f351da948b2fe193b83ba22627dc259fc4adf3540abdca1febe87ec83d68ba64ea37f15c05173b92915cc5d2fa687d8f342ca203eac8a5c1e79ca8d dlib-19.18.tar.bz2"
+
+build() {
+ cd "$srcdir"
+ mkdir -p build && cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ "../$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR=${pkgdir} install
+ install -Dm644 "../$pkgname-$pkgver/dlib/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}