aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 04:57:41 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 08:34:33 -0300
commitb06f8f7311988647b0c008c8d8074694cbf1b296 (patch)
treece7bcaaf0dab604ffdc37087f98768a5148f8409
parent76427e694762a79a95b5ceb6b73537c4db05d5c5 (diff)
downloadaports-b06f8f7311988647b0c008c8d8074694cbf1b296.tar.bz2
aports-b06f8f7311988647b0c008c8d8074694cbf1b296.tar.xz
testing/py3-h5py: upgrade to 2.10.0
-rw-r--r--testing/py3-h5py/APKBUILD48
-rw-r--r--testing/py3-h5py/hdf5-1.10.5.patch27
2 files changed, 12 insertions, 63 deletions
diff --git a/testing/py3-h5py/APKBUILD b/testing/py3-h5py/APKBUILD
index 854dc889c8..904fbbed46 100644
--- a/testing/py3-h5py/APKBUILD
+++ b/testing/py3-h5py/APKBUILD
@@ -1,31 +1,29 @@
# Contributor: James White <stegoxorus@gmail.com>
# Maintainer: James White <stegoxorus@gmail.com>
-pkgname=py-h5py
+pkgname=py3-h5py
_pkgname=h5py
-pkgver=2.9.0
-pkgrel=1
+pkgver=2.10.0
+pkgrel=0
pkgdesc="Read and write HDF5 files from Python"
-# ERROR: test_exc (h5py.tests.old.test_group.TestLen)
-# len() on closed group gives ValueError
-options="!check"
url="https://www.h5py.org"
-arch="all !s390x"
+arch="all !s390x !x86" # x86 -> numpy has no 128float support
license="BSD-3-Clause"
-depends="py-six py-numpy hdf5"
-makedepends="cython python2-dev python3-dev hdf5-dev py-setuptools py-numpy-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-six py3-numpy hdf5"
+makedepends="cython3 python3-dev hdf5-dev py3-setuptools py3-numpy-dev"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- hdf5-1.10.5.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-h5py" # Backwards compatibility
+provides="py-h5py=$pkgver-r$pkgrel" # Backwards compatibility
+
prepare() {
default_prepare
sed -i "s/settings\\['runtime_library_dirs'\\] = settings\\['library_dirs'\\]/pass/" setup_build.py
}
build() {
- python2 setup.py build
python3 setup.py build
}
@@ -34,29 +32,7 @@ check() {
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- replaces="$pkgname"
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="73b1f59e3e2b3eceebf7b97e49bd8f5199afafd7ef29917af05ff8415c2f2129a5c59db9658944370c9bcf8fc04ab26948ee27fc6fd948a22d19cace1ce8c853 h5py-2.9.0.tar.gz
-8fbe88cb9aeda00702402bf10c9719d1b038f63cb788ee32639306cda26aa97f5e854ad8a0aea1d06262ed3b6df1ff4c002297565ddaade4a2865fa8beb1ef53 hdf5-1.10.5.patch"
+sha512sums="c49b04f7dcddf03f36d4f063d79ecbe544e0b1daee432d4a76cfa83dac3a1f2cb144f40a74fb85ea17cb5b778f57f709969ea5d1a2afc5bdd5aecbc9d732898d h5py-2.10.0.tar.gz"
diff --git a/testing/py3-h5py/hdf5-1.10.5.patch b/testing/py3-h5py/hdf5-1.10.5.patch
deleted file mode 100644
index b431d7cd1c..0000000000
--- a/testing/py3-h5py/hdf5-1.10.5.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 141eafa531c6c09a06efe6a694251a1eea84908d Mon Sep 17 00:00:00 2001
-From: Thomas A Caswell <tcaswell@bnl.gov>
-Date: Sun, 17 Mar 2019 16:57:16 -0400
-Subject: [PATCH] TST: bump skip version on attrs test
-
-We are exercising a bug in hdf5, projected to be fixed in 1.10.6 and
-1.12.0
-
-closes #1180
----
- h5py/tests/old/test_attrs.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/h5py/tests/old/test_attrs.py b/h5py/tests/old/test_attrs.py
-index d2e0ab59..46b20e8e 100644
---- a/h5py/tests/old/test_attrs.py
-+++ b/h5py/tests/old/test_attrs.py
-@@ -178,7 +178,7 @@ def fill_attrs(self, track_order):
- attrs[str(i)] = i
- return attrs
-
-- @ut.skipUnless(h5py.version.hdf5_version_tuple >= (1, 10, 5), 'HDF5 1.10.5 required')
-+ @ut.skipUnless(h5py.version.hdf5_version_tuple >= (1, 10, 6), 'HDF5 1.10.6 required')
- # https://forum.hdfgroup.org/t/bug-h5arename-fails-unexpectedly/4881
- def test_track_order(self):
- attrs = self.fill_attrs(track_order=True) # creation order
-