aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-05 15:33:31 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 20:36:42 +0000
commitb0dd43ece680d0cb4f551a1ac0c887d29874f054 (patch)
tree66a6c7cda21542f0e38f46cca18da6edbf75073b
parentd55702c773bd23c7cdc25e21513f0cd7dd825988 (diff)
downloadaports-b0dd43ece680d0cb4f551a1ac0c887d29874f054.tar.bz2
aports-b0dd43ece680d0cb4f551a1ac0c887d29874f054.tar.xz
testing.py3-heapdict: new aport
-rw-r--r--testing/py3-heapdict/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-heapdict/APKBUILD b/testing/py3-heapdict/APKBUILD
new file mode 100644
index 0000000000..44b522aed2
--- /dev/null
+++ b/testing/py3-heapdict/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-heapdict
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="A heap with decrease-key and increase-key operations"
+url="https://stutzbachenterprises.com"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="https://pypi.python.org/packages/source/H/HeapDict/HeapDict-$pkgver.tar.gz"
+options="!check" # Uses internal private API python module
+builddir="$srcdir/HeapDict-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d82e1eaca4b51da1cfd7a43689796523863d4173b4c23aec4c259025dca7775e5aeb58abef66ae8374e996d00aa07e6728d0f2293304202ea0bd3369fb6010be HeapDict-1.0.1.tar.gz"