aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-06 18:04:28 +0300
committerprspkt <prspkt@protonmail.com>2019-06-06 19:09:12 +0300
commitb100c2ebcda3f28e560ec65129fbd28d7402703f (patch)
tree2be96ded932220ea5c6e5a5c01daeb30aa123f49
parent0d59ac5d9295a8e472fe4f7c53e305fadb828dd7 (diff)
downloadaports-b100c2ebcda3f28e560ec65129fbd28d7402703f.tar.bz2
aports-b100c2ebcda3f28e560ec65129fbd28d7402703f.tar.xz
testing/py3-nwdiag: modernize
-rw-r--r--testing/py3-nwdiag/APKBUILD18
1 files changed, 2 insertions, 16 deletions
diff --git a/testing/py3-nwdiag/APKBUILD b/testing/py3-nwdiag/APKBUILD
index 16e44c7429..e892790bb4 100644
--- a/testing/py3-nwdiag/APKBUILD
+++ b/testing/py3-nwdiag/APKBUILD
@@ -4,38 +4,24 @@ pkgname=py3-nwdiag
_pkgname=nwdiag
pkgver=1.0.4
pkgrel=3
-pkgdesc="A Python tool to generate network-diagram image"
+pkgdesc="Generate network-diagram image file from spec-text file"
url="https://pypi.python.org/pypi/nwdiag"
arch="noarch"
license="Apache-2.0"
depends="py3-funcparserlib py3-blockdiag py3-pillow"
makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
replaces="py-nwdiag" # for backwards compatibility
provides="py-nwdiag=$pkgver-r$pkgrel" # for backwards compatibility
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="0d2ff1348aeff53aaf08838d0fa2c001 nwdiag-1.0.4.tar.gz"
-sha256sums="002565875559789a2dfc5f578c07abdf44269c3f7cdf78d4809bdc4bdc2213fa nwdiag-1.0.4.tar.gz"
sha512sums="755493fb8425243117e11d06e7657c9cae44a8c72bc1fbf515a7f38670307fca43bf46c3017b32aa66eece4f389379abb12fcb4914c33fd58e3bb6eff3361f2f nwdiag-1.0.4.tar.gz"