aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-08-08 13:52:20 +0300
committerAndy Postnikov <apostnikov@gmail.com>2019-02-03 03:28:11 +0200
commitb1e0a9912bf0a1d1eec6e0c405b39a6841132e71 (patch)
tree7cac247e241bcba7ff1061f86d3ed9027e2432ab
parent71cd3eb78b20628de1f8fc9d44997e40c9a99e62 (diff)
downloadaports-b1e0a9912bf0a1d1eec6e0c405b39a6841132e71.tar.bz2
aports-b1e0a9912bf0a1d1eec6e0c405b39a6841132e71.tar.xz
testing/php7-xhprof: upgrade to 2.0.5 and enable on s390x
-rw-r--r--testing/php7-xhprof/6507a35d72e9598700e37208c482329594fd3b41.patch48
-rw-r--r--testing/php7-xhprof/APKBUILD12
2 files changed, 5 insertions, 55 deletions
diff --git a/testing/php7-xhprof/6507a35d72e9598700e37208c482329594fd3b41.patch b/testing/php7-xhprof/6507a35d72e9598700e37208c482329594fd3b41.patch
deleted file mode 100644
index d79ea0ee0d..0000000000
--- a/testing/php7-xhprof/6507a35d72e9598700e37208c482329594fd3b41.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 6507a35d72e9598700e37208c482329594fd3b41 Mon Sep 17 00:00:00 2001
-From: longxinhui <longxinhui.e@gmail.com>
-Date: Tue, 7 Aug 2018 11:24:33 +0800
-Subject: [PATCH] Fix memory leaks
-
-#15
----
- extension/php_xhprof.h | 2 +-
- extension/xhprof.c | 6 +++++-
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/extension/php_xhprof.h b/extension/php_xhprof.h
-index 717c56a..bce4e81 100644
---- a/extension/php_xhprof.h
-+++ b/extension/php_xhprof.h
-@@ -142,7 +142,7 @@ do { \
- #define INDEX_2_BYTE(index) (index >> 3)
- #define INDEX_2_BIT(index) (1 << (index & 0x7));
-
--#define register_trace_callback(function_name, cb) zend_hash_str_update(XHPROF_G(trace_callbacks), function_name, sizeof(function_name) - 1, &cb);
-+#define register_trace_callback(function_name, cb) zend_hash_str_update_mem(XHPROF_G(trace_callbacks), function_name, sizeof(function_name) - 1, &cb, sizeof(hp_trace_callback));
-
- /* XHProf maintains a stack of entries being profiled. The memory for the entry
- * is passed by the layer that invokes BEGIN_PROFILING(), e.g. the hp_execute()
-diff --git a/extension/xhprof.c b/extension/xhprof.c
-index c1ecff1..b41768f 100644
---- a/extension/xhprof.c
-+++ b/extension/xhprof.c
-@@ -1633,6 +1633,10 @@ char *hp_get_trace_callback(char* symbol, zend_execute_data *data)
- return result;
- }
-
-+static inline void hp_free_trace_callbacks(zval *val) {
-+ efree(Z_PTR_P(val));
-+}
-+
- void hp_init_trace_callbacks()
- {
- hp_trace_callback callback;
-@@ -1648,7 +1652,7 @@ void hp_init_trace_callbacks()
- return;
- }
-
-- zend_hash_init(XHPROF_G(trace_callbacks), 16, NULL, NULL, 0);
-+ zend_hash_init(XHPROF_G(trace_callbacks), 8, NULL, hp_free_trace_callbacks, 0);
-
- callback = hp_trace_callback_sql_query;
- register_trace_callback("PDO::exec", callback);
diff --git a/testing/php7-xhprof/APKBUILD b/testing/php7-xhprof/APKBUILD
index 6f5aa6622b..041a45682e 100644
--- a/testing/php7-xhprof/APKBUILD
+++ b/testing/php7-xhprof/APKBUILD
@@ -3,17 +3,16 @@
pkgname=php7-xhprof
_pkgreal=xhprof
-pkgver=2.0.2
-pkgrel=1
+pkgver=2.0.5
+pkgrel=0
pkgdesc="A Hierarchical Profiler for PHP"
url="https://github.com/longxinH/xhprof"
-arch="all !s390x"
+arch="all"
license="Apache-2.0"
depends="php7 php7-ctype"
makedepends="php7-dev autoconf"
subpackages="$pkgname-assets::noarch"
-source="$pkgname-$pkgver.tar.gz::https://github.com/longxinH/xhprof/archive/v$pkgver.tar.gz
- 6507a35d72e9598700e37208c482329594fd3b41.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/longxinH/xhprof/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -52,5 +51,4 @@ assets() {
cp -R "$builddir"/examples "$installdir"
}
-sha512sums="6a3ea7994e7d23852d5265371bf59bfa41a3aab2e107b0293b8945adbbda78302ba827f95a54e0780582f06d9487d6e1894ecc2daada20c2ae87fa952e3ffd08 php7-xhprof-2.0.2.tar.gz
-25d87a560cb344b62ba66f2cd0ebec9d512311d9e5c22ff7ab59d70f90b8c9b3e4d1fad0fdbbd8aa28da89328defc3d713525a88f2a42b06c6bd305f57e651b7 6507a35d72e9598700e37208c482329594fd3b41.patch"
+sha512sums="299b5075727112e393425b9a5ed075c06f264c92012d5f49ac9cc52df673766c6bcc796835624327c5ec0f99d687d4d5d22151ac9caf8d276edea597bd564146 php7-xhprof-2.0.5.tar.gz"