aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-09 17:10:35 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:17:25 +0100
commitb241b0527c36991100b4a79846501914ba798537 (patch)
treed2cbb5efb6fd5f49af6d9cd165fe3cef304e2abf
parent817109501917bb0be1a4ae9fd6412f429fee2ca0 (diff)
downloadaports-b241b0527c36991100b4a79846501914ba798537.tar.bz2
aports-b241b0527c36991100b4a79846501914ba798537.tar.xz
community/ocaml-camlp4: upgrade to 4.06.1
-rw-r--r--community/ocaml-camlp4/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/ocaml-camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
index 5f59d60ee8..a37ccbd1f9 100644
--- a/community/ocaml-camlp4/APKBUILD
+++ b/community/ocaml-camlp4/APKBUILD
@@ -4,21 +4,21 @@
pkgname=ocaml-camlp4
_pkgname=camlp4
# NOTE: camlp4 version must match ocaml version!
-pkgver=4.04
-_versuffix='+1'
-_pkgver=$pkgver$_versuffix
-pkgrel=1
+pkgver=4.06.1
+_pkgver="${pkgver%.*}+${pkgver##*.}"
+_ocamlver=${pkgver%.*}
+pkgrel=0
pkgdesc="Caml preprocessor and pretty-printer"
url="https://github.com/ocaml/camlp4/releases"
arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
license="LGPL-2.0-or-later-WITH-linking-exception"
-depends="ocaml"
+depends="ocaml-runtime=~$_ocamlver"
depends_dev="$pkgname=$pkgver-r$pkgrel"
-makedepends="ocamlbuild"
+makedepends="ocaml=~$_ocamlver ocaml-compiler-libs=~$_ocamlver ocamlbuild"
replaces="camlp4" # for backward compatibility
provides="camlp4=$pkgver-r$pkgrel" # for backward compatibility
subpackages="$pkgname-dev"
-source="$_pkgname-$_pkgver.tar.gz::https://github.com/ocaml/$_pkgname/archive/$_pkgver.tar.gz"
+source="$pkgname-$_pkgver.tar.gz::https://github.com/ocaml/$_pkgname/archive/$_pkgver.tar.gz"
builddir="$srcdir/$_pkgname-${_pkgver/+/-}"
build() {
@@ -55,4 +55,4 @@ dev() {
rmdir "$subpkgdir"/$sitelib 2>/dev/null || true
}
-sha512sums="7db8eebcf3d230f60650ba62d9cb630c069394237e97b678a40b61d3dcaded752a2b7e089a50ff528f1ea0740d0291b722df123a072f2cee489cadc5201c6776 camlp4-4.04+1.tar.gz"
+sha512sums="32be92c4e64a985a3d2880e2201351961a4b7138a8be6e3f17e9b8e038a1660d13596f29fe0249c8c4183cd8cd06277cebc58f42609c8d2028032e893490fe43 ocaml-camlp4-4.06+1.tar.gz"