aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-21 01:24:30 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-10-21 01:30:11 +0300
commitb3d534d73c690baf458d9cda5dca5ee52ca9cafc (patch)
treecf6d9e2406a950dc7847915921868306646d56f7
parentcab22533c14a5d8d9943401348102343d34df48d (diff)
downloadaports-b3d534d73c690baf458d9cda5dca5ee52ca9cafc.tar.bz2
aports-b3d534d73c690baf458d9cda5dca5ee52ca9cafc.tar.xz
community/php7-pecl-mongodb: renamed from php7-mongodb, fix license
-rw-r--r--community/php7-pecl-mongodb/APKBUILD (renamed from community/php7-mongodb/APKBUILD)8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/php7-mongodb/APKBUILD b/community/php7-pecl-mongodb/APKBUILD
index d4afc6563a..f1ef9852b2 100644
--- a/community/php7-mongodb/APKBUILD
+++ b/community/php7-pecl-mongodb/APKBUILD
@@ -1,19 +1,21 @@
# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
-pkgname=php7-mongodb
+pkgname=php7-pecl-mongodb
_pkgreal=mongodb
pkgver=1.5.3
_pkgver=${pkgver/_rc/RC}
-pkgrel=0
+pkgrel=1
pkgdesc="PHP7 MongoDB driver"
url="https://pecl.php.net/package/mongodb"
arch="all"
-license="PHP"
+license="Apache-2.0"
depends="php7-json"
makedepends="libressl-dev pcre-dev php7-dev autoconf"
source="https://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
options="!check" # tests requires additional dependencies (vagrant)
builddir="$srcdir"/$_pkgreal-$_pkgver
+provides="php7-mongodb=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-mongodb" # for backward compatibility
build() {
cd "$builddir"