aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-26 14:34:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-26 14:34:14 +0000
commitb9807df83b6ab649d915bca53299dd73b1db0897 (patch)
tree135585d951c8368b255c1d4b120640914400a9ae
parent6073409488faf0051dc1f188042f444bbd4c4743 (diff)
downloadaports-b9807df83b6ab649d915bca53299dd73b1db0897.tar.bz2
aports-b9807df83b6ab649d915bca53299dd73b1db0897.tar.xz
community/py-mysqldb: build fix
we dont need my_config.h
-rw-r--r--community/py-mysqldb/APKBUILD5
-rw-r--r--community/py-mysqldb/mariadb.patch13
2 files changed, 13 insertions, 5 deletions
diff --git a/community/py-mysqldb/APKBUILD b/community/py-mysqldb/APKBUILD
index 797c0da91a..8cb7045ec5 100644
--- a/community/py-mysqldb/APKBUILD
+++ b/community/py-mysqldb/APKBUILD
@@ -8,8 +8,7 @@ url="https://github.com/farcepest/MySQLdb1"
arch="all"
license="GPL"
depends="python2"
-depends_dev="mariadb-connector-c-dev"
-makedepends="$depends_dev python2-dev py-setuptools"
+makedepends="mariadb-connector-c-dev python2-dev py-setuptools"
source="https://files.pythonhosted.org/packages/source/M/MySQL-python/MySQL-python-$pkgver.zip
mariadb.patch"
@@ -26,4 +25,4 @@ package() {
}
sha512sums="37521c6fd855c4cde495cc8ec085aca79c2d441a6e3710759385bf2e2c17f43d3311cf1166663892829d2e3999c419443c358c7031cdda225ac44611ced188d0 MySQL-python-1.2.5.zip
-edc8b1fc11c4dfbc4af42b9a2122bf8adb0bc32ae593606be0bda6a2a5987f47e5136281c7d1b10f84aa6643ecb93f45853960153a4701e49e42ea4158d34ec0 mariadb.patch"
+fcb15e47a1cc5faa9c6ef33826a661d2728a0bd59ee2d35f7046b5079875741574a3a80ff95f86b419fd6ae58d59fce8f391b1d0630aaec034098054683487ca mariadb.patch"
diff --git a/community/py-mysqldb/mariadb.patch b/community/py-mysqldb/mariadb.patch
index a2cbd8574b..ed7d496f63 100644
--- a/community/py-mysqldb/mariadb.patch
+++ b/community/py-mysqldb/mariadb.patch
@@ -1,8 +1,17 @@
diff --git a/_mysql.c b/_mysql.c
-index f081346..481617e 100644
+index f081346..1c434d3 100644
--- a/_mysql.c
+++ b/_mysql.c
-@@ -2002,7 +2002,7 @@ _mysql_ConnectionObject_ping(
+@@ -40,8 +40,6 @@ PERFORMANCE OF THIS SOFTWARE.
+ #include "structmember.h"
+ #if defined(MS_WINDOWS)
+ #include <config-win.h>
+-#else
+-#include "my_config.h"
+ #endif
+ #include "mysql.h"
+ #include "mysqld_error.h"
+@@ -2002,7 +2000,7 @@ _mysql_ConnectionObject_ping(
int r, reconnect = -1;
if (!PyArg_ParseTuple(args, "|I", &reconnect)) return NULL;
check_connection(self);