aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-23 00:09:03 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-23 00:17:10 +0100
commitbc455acb7486315c7a34a8a4ace0cb08b2d630b5 (patch)
tree34315adbe0d7be8ccf1da0d33332daedb93be895
parentde4eb13468b123dd585eca72888bec6328db7e0e (diff)
downloadaports-bc455acb7486315c7a34a8a4ace0cb08b2d630b5.tar.bz2
aports-bc455acb7486315c7a34a8a4ace0cb08b2d630b5.tar.xz
community/py3-pytest-xdist: upgrade to 1.31.0
-rw-r--r--community/py3-pytest-xdist/APKBUILD9
-rw-r--r--community/py3-pytest-xdist/fix-acceptance-tests.patch40
2 files changed, 4 insertions, 45 deletions
diff --git a/community/py3-pytest-xdist/APKBUILD b/community/py3-pytest-xdist/APKBUILD
index e1a374bd5e..26545b2684 100644
--- a/community/py3-pytest-xdist/APKBUILD
+++ b/community/py3-pytest-xdist/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
pkgname=py3-pytest-xdist
-pkgver=1.30.0
-pkgrel=1
+pkgver=1.31.0
+pkgrel=0
pkgdesc="pytest xdist plugin for distributed testing and loop-on-failing modes"
url="https://github.com/pytest-dev/pytest-xdist"
arch="noarch"
@@ -10,8 +10,7 @@ license="MIT"
depends="py3-execnet py3-pytest py3-pytest-forked py3-six"
checkdepends="py3-filelock py3-py"
makedepends="py3-setuptools py3-setuptools_scm"
-source="https://files.pythonhosted.org/packages/source/p/pytest-xdist/pytest-xdist-$pkgver.tar.gz
- fix-acceptance-tests.patch"
+source="https://files.pythonhosted.org/packages/source/p/pytest-xdist/pytest-xdist-$pkgver.tar.gz"
builddir="$srcdir/pytest-xdist-$pkgver"
replaces="pytest-xdist" # Backwards compatibility
@@ -32,5 +31,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="978b67df2366d916db62af21f2c610ac5d2de43cecf3260ec9bf52f904098514c3052ce8ca2195c17addd4012f3c5d38ce8a701d26c8158142a821b0d0cf9122 pytest-xdist-1.30.0.tar.gz
+sha512sums="b7960d20295232b251c8ddcc5a3b9d6e7b761d577ba11c2647b4b4b410ee5c05998cf57fa57208561eb3ea7c4914db1fd446173794589d8c8e8e79ff8e0ad3aa pytest-xdist-1.31.0.tar.gz
97494d31912dbb1631bd3c659dae75809c63474abd600e98a5ec28b43c3e8e8ae49faf3c482fb52516c678b094f86ba554e2da3a7f6e3f9c22d6ad0bb289c4cb fix-acceptance-tests.patch"
diff --git a/community/py3-pytest-xdist/fix-acceptance-tests.patch b/community/py3-pytest-xdist/fix-acceptance-tests.patch
deleted file mode 100644
index 5d039862e7..0000000000
--- a/community/py3-pytest-xdist/fix-acceptance-tests.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/testing/acceptance_test.py b/testing/acceptance_test.py
-index 4537fd0bed..e3a6f5b73c 100644
---- a/testing/acceptance_test.py
-+++ b/testing/acceptance_test.py
-@@ -784,7 +784,7 @@ class TestWarnings:
- )
- )
- result = testdir.runpytest(n)
-- result.stdout.fnmatch_lines(["*this is a warning*", "*1 passed, 1 warnings*"])
-+ result.stdout.fnmatch_lines(["*this is a warning*", "*1 passed, 1 warning*"])
-
- @pytest.mark.parametrize("n", ["-n0", "-n1"])
- def test_custom_subclass(self, testdir, n):
-@@ -808,7 +808,7 @@ class TestWarnings:
- )
- testdir.syspathinsert()
- result = testdir.runpytest(n)
-- result.stdout.fnmatch_lines(["*MyWarning*", "*1 passed, 1 warnings*"])
-+ result.stdout.fnmatch_lines(["*MyWarning*", "*1 passed, 1 warning*"])
-
- @pytest.mark.parametrize("n", ["-n0", "-n1"])
- def test_unserializable_arguments(self, testdir, n):
-@@ -825,7 +825,7 @@ class TestWarnings:
- )
- testdir.syspathinsert()
- result = testdir.runpytest(n)
-- result.stdout.fnmatch_lines(["*UserWarning*foo.txt*", "*1 passed, 1 warnings*"])
-+ result.stdout.fnmatch_lines(["*UserWarning*foo.txt*", "*1 passed, 1 warning*"])
-
- @pytest.mark.parametrize("n", ["-n0", "-n1"])
- def test_unserializable_warning_details(self, testdir, n):
-@@ -857,7 +857,7 @@ class TestWarnings:
- testdir.syspathinsert()
- result = testdir.runpytest(n)
- result.stdout.fnmatch_lines(
-- ["*ResourceWarning*unclosed*", "*1 passed, 1 warnings*"]
-+ ["*ResourceWarning*unclosed*", "*1 passed, 1 warning*"]
- )
-
-