aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-25 15:47:43 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-25 16:09:28 +0100
commitbce32815ec41b8144c99eb02cefd3fb05b2c74ee (patch)
treec2770eac9ba089da2e861395be96eb848e16769e
parent11c42c35632ded5b149aca0a598aa84646bac751 (diff)
downloadaports-bce32815ec41b8144c99eb02cefd3fb05b2c74ee.tar.bz2
aports-bce32815ec41b8144c99eb02cefd3fb05b2c74ee.tar.xz
community/clsync: upgrade to 0.4.3
-rw-r--r--community/clsync/APKBUILD16
-rw-r--r--community/clsync/musl-fix.patch26
2 files changed, 19 insertions, 23 deletions
diff --git a/community/clsync/APKBUILD b/community/clsync/APKBUILD
index c38cbcc305..77746a5d3d 100644
--- a/community/clsync/APKBUILD
+++ b/community/clsync/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=clsync
-pkgver=0.4.2
-pkgrel=1
+pkgver=0.4.3
+pkgrel=0
pkgdesc="File live sync daemon based on inotify"
url="https://github.com/xaionaro/clsync"
arch="x86 x86_64 aarch64"
@@ -10,8 +10,9 @@ license="GPL-3.0-or-later"
depends_dev="glib-dev fts-dev libcap-dev libexecinfo-dev linux-headers musl-dev"
makedepends="$depends_dev autoconf automake file libtool"
subpackages="$pkgname-doc $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/xaionaro/$pkgname/archive/v$pkgver.tar.gz
- musl-fix.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xaionaro/clsync/archive/v$pkgver.tar.gz
+ musl-fix.patch
+ "
options="!check" # upstream does not provide tests
prepare() {
@@ -42,10 +43,7 @@ build() {
package() {
make DESTDIR="$pkgdir" install
-
- # https://github.com/xaionaro/clsync/issues/150
- rm "$pkgdir"/usr/bin/gencompilerflags
}
-sha512sums="d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200 clsync-0.4.2.tar.gz
-98e81408911731f6e203368094ea0e9eda312648eef8c5beec98b13c6ee43bccee59f0777805bea4d26cbe4e964d2ff95fe863be5be7750b50358d213f106542 musl-fix.patch"
+sha512sums="ab803cc04cd2efd5902ea54ae3f7dc29fd88fc01b70f90112f188b60bb45fe79e255a91df3fa429d0b0f4fb6f67ea453d732a53b4db44d9f85077230d9095e4a clsync-0.4.3.tar.gz
+3302e4d565c6647f27c5e24325a81eaf4789735a944b749a4f5b4372558c65ca4b8acd26eec097d965bc1c811597915c46eed75f697cb930e03a8113e20a1d82 musl-fix.patch"
diff --git a/community/clsync/musl-fix.patch b/community/clsync/musl-fix.patch
index a0dc31e9f2..ad219be3b3 100644
--- a/community/clsync/musl-fix.patch
+++ b/community/clsync/musl-fix.patch
@@ -1,23 +1,21 @@
-musl declares lstat64 only for GNU compatibility using macro
-`#define lstat64 lstat`. Local variable lstat in mon_gio overrides
-global function lstat from sys/stat.h.
-
-Upstream issue: https://github.com/xaionaro/clsync/issues/150
+diff --git a/mon_gio.c b/mon_gio.c
+index 80bec82..c28ccb3 100644
--- a/mon_gio.c
+++ b/mon_gio.c
-@@ -305,18 +305,18 @@
- count = 0;
- while (gio_wait(ctx_p, indexes_p, &tv)) {
+@@ -316,19 +316,19 @@ int gio_handle ( ctx_t *ctx_p, indexes_t *indexes_p )
+
+ while ( gio_wait ( ctx_p, indexes_p, &tv ) ) {
event_t *ev = event_pop();
- stat64_t lstat, *lstat_p;
+ stat64_t _lstat, *lstat_p;
mode_t st_mode;
size_t st_size;
-- if ((ev->objtype_new == EOT_DOESNTEXIST) || (ctx_p->flags[CANCEL_SYSCALLS]&CSC_MON_STAT) || lstat64(ev->path, &lstat)) {
-- debug(2, "Cannot lstat64(\"%s\", lstat). Seems, that the object had been deleted (%i) or option \"--cancel-syscalls mon_stat\" (%i) is set.", ev->path, ev->objtype_new == EOT_DOESNTEXIST, ctx_p->flags[CANCEL_SYSCALLS]&CSC_MON_STAT);
-+ if ((ev->objtype_new == EOT_DOESNTEXIST) || (ctx_p->flags[CANCEL_SYSCALLS]&CSC_MON_STAT) || lstat64(ev->path, &_lstat)) {
-+ debug(2, "Cannot lstat64(\"%s\", _lstat). Seems, that the object had been deleted (%i) or option \"--cancel-syscalls mon_stat\" (%i) is set.", ev->path, ev->objtype_new == EOT_DOESNTEXIST, ctx_p->flags[CANCEL_SYSCALLS]&CSC_MON_STAT);
- st_mode = (ev->objtype_event == EOT_DIR ? S_IFDIR : S_IFREG);
+
+- if ( ( ev->objtype_new == EOT_DOESNTEXIST ) || ( ctx_p->flags[CANCEL_SYSCALLS]&CSC_MON_STAT ) || lstat64 ( ev->path, &lstat ) ) {
+- debug ( 2, "Cannot lstat64(\"%s\", lstat). Seems, that the object had been deleted (%i) or option \"--cancel-syscalls mon_stat\" (%i) is set.", ev->path, ev->objtype_new == EOT_DOESNTEXIST, ctx_p->flags[CANCEL_SYSCALLS]&CSC_MON_STAT );
++ if ( ( ev->objtype_new == EOT_DOESNTEXIST ) || ( ctx_p->flags[CANCEL_SYSCALLS]&CSC_MON_STAT ) || lstat64 ( ev->path, &_lstat ) ) {
++ debug ( 2, "Cannot lstat64(\"%s\", _lstat). Seems, that the object had been deleted (%i) or option \"--cancel-syscalls mon_stat\" (%i) is set.", ev->path, ev->objtype_new == EOT_DOESNTEXIST, ctx_p->flags[CANCEL_SYSCALLS]&CSC_MON_STAT );
+ st_mode = ( ev->objtype_event == EOT_DIR ? S_IFDIR : S_IFREG );
st_size = 0;
lstat_p = NULL;
} else {
@@ -29,4 +27,4 @@ Upstream issue: https://github.com/xaionaro/clsync/issues/150
+ lstat_p = &_lstat;
}
- if (sync_prequeue_loadmark(1, ctx_p, indexes_p, NULL, ev->path, lstat_p, ev->objtype_old, ev->objtype_new, ev->event_id, ev->handle_id, st_mode, st_size, &path_full, &path_full_len, NULL)) {
+ if ( sync_prequeue_loadmark ( 1, ctx_p, indexes_p, NULL, ev->path, lstat_p, ev->objtype_old, ev->objtype_new, ev->event_id, ev->handle_id, st_mode, st_size, &path_full, &path_full_len, NULL ) ) {