aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2018-01-06 16:34:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-02-27 17:43:25 +0000
commitbd3d03d8d9056987d352c37c514cb9e8369a32b3 (patch)
treec583c26bf2787c5fb0274ca4d8c080e4d813eea0
parent341613adc6c770987a69b9a09a54db09e0b62c12 (diff)
downloadaports-bd3d03d8d9056987d352c37c514cb9e8369a32b3.tar.bz2
aports-bd3d03d8d9056987d352c37c514cb9e8369a32b3.tar.xz
testing/perl-test-file: new aport
-rw-r--r--testing/perl-test-file/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/perl-test-file/APKBUILD b/testing/perl-test-file/APKBUILD
new file mode 100644
index 0000000000..830f9cc529
--- /dev/null
+++ b/testing/perl-test-file/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=perl-test-file
+_realname=Test-File
+pkgver=1.443
+pkgrel=0
+pkgdesc="A collection of test utilities for file attributes"
+url="https://github.com/briandfoy/test-file"
+arch="noarch"
+license="PerlArtistic"
+depends=""
+makedepends="perl-dev"
+checkdepends="perl-test-utf8"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BD/BDFOY/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="9ad66b3a9dc1c3752a4ec22934db9139ac010ac3237a3de018d4ec4a65ac047f0152ab9e7979a2615412c1af02a1f2dfa0dbfdf5eba5358628b1b443232c45b2 Test-File-1.443.tar.gz"