aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-02-07 22:20:07 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2019-02-07 22:23:21 +0100
commitbd42e2a3f2bd8452367747b5b43ca77f50b9152f (patch)
tree45843eec8017ef736f33afcc5012d2eaa3b4a220
parent286ff3087c5147a3367d8c1711dce1890616ae8a (diff)
downloadaports-bd42e2a3f2bd8452367747b5b43ca77f50b9152f.tar.bz2
aports-bd42e2a3f2bd8452367747b5b43ca77f50b9152f.tar.xz
testing/numactl: add check()
Only run checks that does not require a physical node with numa topology.
-rw-r--r--testing/numactl/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/numactl/APKBUILD b/testing/numactl/APKBUILD
index 96f5c7ee30..dec2786503 100644
--- a/testing/numactl/APKBUILD
+++ b/testing/numactl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=numactl
pkgver=2.0.12
-pkgrel=0
+pkgrel=1
pkgdesc="Simple NUMA policy support"
url="https://github.com/numactl/numactl"
# ARM lacks the __NR_migrate_pages syscall
@@ -9,7 +9,6 @@ arch="all !armhf !armv7"
license="GPL-2.0 LGPL-2.0"
makedepends="autoconf automake libtool linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/numactl/$pkgname/archive/v$pkgver.tar.gz
musl.patch"
builddir="$srcdir/$pkgname-$pkgver"
@@ -21,6 +20,11 @@ prepare() {
./autogen.sh
}
+check() {
+ cd "$builddir"
+ make check VERBOSE=1 TESTS='test/distance test/nodemap test/tbitmap'
+}
+
build() {
cd "$builddir"
./configure \