aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShyam Sunder <sgsunder1@gmail.com>2019-06-30 13:09:42 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-05 15:44:09 -0300
commitbde5d60a4ef124bb93eb835fed33ca5a83f4c3c5 (patch)
tree363eb63cfa055f6eac98e9fa4e3735c6598e2fd2
parentfc2cfa7ad4c4b05f5ea30af5690263edec8abaef (diff)
downloadaports-bde5d60a4ef124bb93eb835fed33ca5a83f4c3c5.tar.bz2
aports-bde5d60a4ef124bb93eb835fed33ca5a83f4c3c5.tar.xz
testing/zfsnap: new aport
https://www.zfsnap.org/ A portable, performant script to make rolling ZFS snapshots easy
-rw-r--r--testing/zfsnap/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/testing/zfsnap/APKBUILD b/testing/zfsnap/APKBUILD
new file mode 100644
index 0000000000..7142b6e4fe
--- /dev/null
+++ b/testing/zfsnap/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Shyam Sunder <sgsunder1@gmail.com>
+# Maintainer: Shyam Sunder <sgsunder1@gmail.com>
+pkgname="zfsnap"
+pkgver="2.0.0b3"
+pkgrel=0
+pkgdesc="A portable, performant script to make rolling ZFS snapshots easy"
+url="https://www.zfsnap.org/"
+arch="noarch !armhf !armv7" # Limited by zfs
+license="BSD-3-Clause"
+depends="zfs"
+options="!check" # no unit tests, only consists of shell scripts
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
+source="https://github.com/zfsnap/zfsnap/archive/v2.0.0-beta3.tar.gz"
+builddir="$srcdir/$pkgname-2.0.0-beta3"
+
+prepare() {
+ default_prepare
+ sed -i \
+ -e 's#/sbin/zfs#/usr/sbin/zfs#g' \
+ -e 's#/sbin/zpool#/usr/sbin/zpool#g' \
+ "$builddir"/share/zfsnap/core.sh
+}
+
+package() {
+ install -Dm755 "$builddir"/sbin/zfsnap.sh \
+ "$pkgdir"/usr/sbin/zfsnap
+ install -Dm755 "$builddir"/share/zfsnap/core.sh \
+ "$pkgdir"/usr/share/zfsnap/core.sh
+ install -Dm755 "$builddir"/share/zfsnap/commands/destroy.sh \
+ "$pkgdir"/usr/share/zfsnap/commands/destroy.sh
+ install -Dm755 "$builddir"/share/zfsnap/commands/recurseback.sh \
+ "$pkgdir"/usr/share/zfsnap/commands/recurseback.sh
+ install -Dm755 "$builddir"/share/zfsnap/commands/snapshot.sh \
+ "$pkgdir"/usr/share/zfsnap/commands/snapshot.sh
+ install -Dm644 "$builddir"/man/man8/zfsnap.8 \
+ "$pkgdir"/usr/share/man/man8/zfsnap.8
+}
+
+bashcomp() {
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ install -Dm644 "$builddir"/completion/$pkgname-completion.bash \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+}
+
+zshcomp() {
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ install -Dm644 "$builddir"/completion/$pkgname-completion.zsh \
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
+}
+
+sha512sums="85df793abd97a3db26fcb9d779627ea295b2132dc462c3b1afc70a877d8093196992a7912957157555714c5f1e07ae1694e7fbed9ebae2482fd5f2d846eaf694 v2.0.0-beta3.tar.gz"