aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2019-02-14 05:33:02 +0100
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2019-02-14 23:39:16 +0200
commitbe9c8ed89dc93d2236b9223dde842f5676e4dfd3 (patch)
tree2a5c5e6219999811c4d60012d4f324e4ae1c2e45
parenteb3ede8d1152a78e5fa36cfbe8bc58feef99fc4c (diff)
downloadaports-be9c8ed89dc93d2236b9223dde842f5676e4dfd3.tar.bz2
aports-be9c8ed89dc93d2236b9223dde842f5676e4dfd3.tar.xz
main/apache2: Create /run folder for apache2 on install
The directory /run/apache2 is only created when running in openrc (see apache2.initd). When installing on a non-openrc system (e.g. docker), this folder is missing and apache2 refuses to start. Closes https://bugs.alpinelinux.org/issues/9982
-rw-r--r--main/apache2/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/apache2/APKBUILD b/main/apache2/APKBUILD
index 45aa11766c..45fc04f33d 100644
--- a/main/apache2/APKBUILD
+++ b/main/apache2/APKBUILD
@@ -3,7 +3,7 @@
pkgname=apache2
_pkgreal=httpd
pkgver=2.4.38
-pkgrel=1
+pkgrel=2
pkgdesc="A high performance Unix-based HTTP server"
url="https://httpd.apache.org/"
arch="all"
@@ -172,6 +172,10 @@ package() {
error "$i MPM was not built"
fi
done
+
+ # create the run directory
+ # ref #9982
+ mkdir -p "$pkgdir"/run/apache2
}
_make_conf_dir() {