aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-22 23:19:05 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-22 23:19:05 -0600
commitbf2b72da774feb628bb66c0e32dedb811fa5d124 (patch)
tree1810ede8accea8ab57bec3d8cdf43c342bfa374f
parent762178ae3fc46fb1004d231da2a15dd441ce7f90 (diff)
downloadaports-bf2b72da774feb628bb66c0e32dedb811fa5d124.tar.bz2
aports-bf2b72da774feb628bb66c0e32dedb811fa5d124.tar.xz
testing/metacity: new aport
-rw-r--r--testing/metacity/APKBUILD52
-rw-r--r--testing/metacity/metacity.post-install7
-rw-r--r--testing/metacity/metacity.post-upgrade7
-rw-r--r--testing/metacity/metacity.pre-deinstall7
4 files changed, 73 insertions, 0 deletions
diff --git a/testing/metacity/APKBUILD b/testing/metacity/APKBUILD
new file mode 100644
index 0000000000..ed8c13b29e
--- /dev/null
+++ b/testing/metacity/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=metacity
+pkgver=2.30.3
+pkgrel=0
+pkgdesc="GTK+ window manager"
+url="http://projects.gnome.org/metacity"
+arch="all"
+license="GPL"
+depends="zenity"
+depends_dev="gtk+-dev
+ gconf-dev
+ libx11-dev
+ gnome-doc-utils
+ libgnome-dev
+ gnome-desktop-dev
+ libwnck-dev
+ librsvg-dev
+ libxcomposite-dev"
+makedepends="$depends_dev intltool gobject-introspection"
+install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
+subpackages=
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-compositor \
+ --disable-scrollkeeper || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="553784f376d96b902e19ff437cd5b339 metacity-2.30.3.tar.bz2"
diff --git a/testing/metacity/metacity.post-install b/testing/metacity/metacity.post-install
new file mode 100644
index 0000000000..4b16502e4a
--- /dev/null
+++ b/testing/metacity/metacity.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in metacity.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/testing/metacity/metacity.post-upgrade b/testing/metacity/metacity.post-upgrade
new file mode 100644
index 0000000000..4b16502e4a
--- /dev/null
+++ b/testing/metacity/metacity.post-upgrade
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in metacity.schemas; do
+ echo "Installing GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
+done
diff --git a/testing/metacity/metacity.pre-deinstall b/testing/metacity/metacity.pre-deinstall
new file mode 100644
index 0000000000..3fab274c9e
--- /dev/null
+++ b/testing/metacity/metacity.pre-deinstall
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+for i in metacity.schemas; do
+ echo "Uninstalling GConf2 schema $i."
+ GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
+ /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
+done