aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-09 12:06:36 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-09 11:21:25 +0000
commitbfd07de95c94f6e6d79f26360f891a17e8aac1c4 (patch)
tree0af5abb131c5eda1773415ad1484432a43b724b8
parentfb1559b8f589bb2094238ce1e30691f9306014e4 (diff)
downloadaports-bfd07de95c94f6e6d79f26360f891a17e8aac1c4.tar.bz2
aports-bfd07de95c94f6e6d79f26360f891a17e8aac1c4.tar.xz
community/firefox: use our new Rust triplets
-rw-r--r--community/firefox/APKBUILD32
-rw-r--r--community/firefox/x86_64-alpine-linux-musl.json35
2 files changed, 2 insertions, 65 deletions
diff --git a/community/firefox/APKBUILD b/community/firefox/APKBUILD
index ea3416c4f5..e4eaa93c6e 100644
--- a/community/firefox/APKBUILD
+++ b/community/firefox/APKBUILD
@@ -68,7 +68,6 @@ source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkg
fd6847c9416f9eebde636e21d794d25d1be8791d.patch
allow-custom-rust-vendor.patch
- x86_64-alpine-linux-musl.json
firefox.desktop
firefox-safe.desktop
remove-faulty-libvpx-check.patch
@@ -141,10 +140,6 @@ prepare() {
default_prepare
cp "$srcdir"/stab.h toolkit/crashreporter/google-breakpad/src/
- # Firefox needs to know how our custom triplet on x86_64 behaves.
- mkdir rust_targets
- cp "$srcdir"/x86_64-alpine-linux-musl.json rust_targets/.
-
_clear_vendor_checksums audio_thread_priority
_clear_vendor_checksums target-lexicon-0.9.0
}
@@ -158,37 +153,15 @@ build() {
export MOZILLA_OFFICIAL=1
export USE_SHORT_LIBNAME=1
# Find our triplet JSON
- export RUST_TARGET_PATH="$builddir/rust_targets"
+ export RUST_TARGET="$CTARGET"
# set rpath so linker finds the libs
export LDFLAGS="$LDFLAGS -Wl,-rpath,$_mozappdir"
case "$CARCH" in
- x86)
+ arm*|x86*)
# disable-elf-hack: exists only on arm, x86, x86_64
_arch_config="--disable-elf-hack"
- export RUST_TARGET="i686-unknown-linux-musl"
- ;;
- x86_64)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="$CTARGET"
- ;;
- aarch64)
- export RUST_TARGET="aarch64-unknown-linux-musl"
- ;;
- armv7)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="armv7-unknown-linux-musleabihf"
- ;;
- armhf)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="arm-unknown-linux-musleabihf"
- ;;
- ppc64le)
- export RUST_TARGET="powerpc64le-unknown-linux-musl"
;;
esac
@@ -291,7 +264,6 @@ a4a3e062661bda64d502d426c480ac9645345860118de9df9ffe6e0597738c70c11e5cdef2d4fd12
d35cacb9ede80e6bfbef0709823e536dddfb1c02d776275b0b7adb5969e9927d8c6117df96873569c3f3db0a18ee5db24f8086a9311a05077892be43a3dd8d79 fix-webrtc-glibcisms.patch
60845dcb034b2c4459c30f7d5f25c8176cf42df794e2cc0e86c3e2abb6541c24b962f3a16ca70a288d4d6f377b68d00b2904b22463108559612053d835d9bff1 fd6847c9416f9eebde636e21d794d25d1be8791d.patch
4e584621145cf8add069c6dac18e805b3274a1ee402d84e924df2341f7d3c5be261a93ef51283bacbd606f47fbdc628c4323ecc31efc5b403b8d224b18dc278f allow-custom-rust-vendor.patch
-0dfa633abf3f411c90a030c46ee7f8fdde6fdd9f3a0c493599a58633e09b183d6c04590fc1984256e514c1da4f72f43dde3f5dbceef888b08262952b4f894919 x86_64-alpine-linux-musl.json
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop
bb75b2abda86e455d81571052a2cfec5a9d858ffa91c50a7217b4b6c02cbfc0400e9114a27bd54ce78d7d3a44e9b03927cf0317654d98c0f39d26c63c9670117 remove-faulty-libvpx-check.patch
diff --git a/community/firefox/x86_64-alpine-linux-musl.json b/community/firefox/x86_64-alpine-linux-musl.json
deleted file mode 100644
index 5062c38e7e..0000000000
--- a/community/firefox/x86_64-alpine-linux-musl.json
+++ /dev/null
@@ -1,35 +0,0 @@
-{
- "arch": "x86_64",
- "cpu": "x86-64",
- "crt-static-default": false,
- "crt-static-respected": true,
- "data-layout": "e-m:e-i64:64-f80:128-n8:16:32:64-S128",
- "dynamic-linking": true,
- "env": "musl",
- "executables": true,
- "has-elf-tls": true,
- "has-rpath": true,
- "is-builtin": true,
- "linker-flavor": "gcc",
- "linker-is-gnu": true,
- "llvm-target": "x86_64-unknown-linux-musl",
- "max-atomic-width": 64,
- "os": "linux",
- "position-independent-executables": true,
- "pre-link-args": {
- "gcc": [
- "-Wl,--as-needed",
- "-Wl,-z,noexecstack",
- "-Wl,--eh-frame-hdr",
- "-m64"
- ]
- },
- "relro-level": "full",
- "stack-probes": true,
- "target-c-int-width": "32",
- "target-endian": "little",
- "target-family": "unix",
- "target-pointer-width": "64",
- "vendor": "alpine"
-}
-