aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-09-09 13:37:13 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 10:45:31 -0300
commitc015d4585c37655339d79e68006879beb9b79476 (patch)
treecacf387dbfe80a3cacff53ba4f972584ea564425
parentec428d9c9622619788d8bb79dce7695a943a02fa (diff)
downloadaports-c015d4585c37655339d79e68006879beb9b79476.tar.bz2
aports-c015d4585c37655339d79e68006879beb9b79476.tar.xz
community/plymouth: add required sysmacros.h
-rw-r--r--community/plymouth/APKBUILD6
-rw-r--r--community/plymouth/plymouth-add-sysmacros.patch10
2 files changed, 14 insertions, 2 deletions
diff --git a/community/plymouth/APKBUILD b/community/plymouth/APKBUILD
index 86d0d5bd7e..93aff927cd 100644
--- a/community/plymouth/APKBUILD
+++ b/community/plymouth/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=plymouth
pkgver=0.9.2
-pkgrel=2
+pkgrel=3
pkgdesc="graphical bootsplash on linux"
url="http://www.freedesktop.org/wiki/Software/Plymouth"
arch="all"
@@ -15,6 +15,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-themes $pkgname-x11:_render $pkg
source="https://www.freedesktop.org/software/$pkgname/releases/$pkgname-$pkgver.tar.bz2
plymouth-rpmatch.patch
plymouth-git-master-20170123.patch
+ plymouth-add-sysmacros.patch
"
builddir="$srcdir"/plymouth-$pkgver
@@ -56,4 +57,5 @@ _render() {
sha512sums="89356eb8326504fbf3155de262ce15de0847f0a0e6d157d873cf1dea9af464a6cb9e11d7143ee9a595b217a2487060b5835eba5ac142c3cd6d66689deb272e60 plymouth-0.9.2.tar.bz2
ec1c32ddf7ee418ef1b5d173040db464193d9bca3fd85d5c3a8d2ee13ba1218947f7c9f39c403d3ccced70be28b2c7328e82dc8f967e9bdeea1651dee4be2dc7 plymouth-rpmatch.patch
-6545c29190b9cf04df0284a73c26ec7d14fddf2c4d7a8f3dff5242b49fafda24ee2aeab54b44b19deb9228707816b6b3779ea8bec7b742020cb1f7e2ca64b509 plymouth-git-master-20170123.patch"
+6545c29190b9cf04df0284a73c26ec7d14fddf2c4d7a8f3dff5242b49fafda24ee2aeab54b44b19deb9228707816b6b3779ea8bec7b742020cb1f7e2ca64b509 plymouth-git-master-20170123.patch
+b55d9bfad1de809334ee24a89496335e369e6e9a78eed2576ea93882d100dfddb09dbd05588fe478da6f9c50ae03c920defd8a352a93f2e149c39df1810a48c1 plymouth-add-sysmacros.patch"
diff --git a/community/plymouth/plymouth-add-sysmacros.patch b/community/plymouth/plymouth-add-sysmacros.patch
new file mode 100644
index 0000000000..90c011955f
--- /dev/null
+++ b/community/plymouth/plymouth-add-sysmacros.patch
@@ -0,0 +1,10 @@
+--- a/src/libply-splash-core/ply-terminal.c
++++ b/src/libply-splash-core/ply-terminal.c
+@@ -32,6 +32,7 @@
+ #include <sys/socket.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <termios.h>
+ #include <unistd.h>
+ #include <wchar.h>