aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-20 22:44:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-20 22:44:57 -0300
commitc1dc6d3e6c6f4a2e8fc82bb7d4aae6e13c0ed901 (patch)
tree9a82c90d3360452aaf6e934e37a378d4f7dc8a6f
parent4f937293f04b5ea85e897e08d9b06eeed5cbd999 (diff)
downloadaports-c1dc6d3e6c6f4a2e8fc82bb7d4aae6e13c0ed901.tar.bz2
aports-c1dc6d3e6c6f4a2e8fc82bb7d4aae6e13c0ed901.tar.xz
community/perl-data-compare: upgrade to 1.26
-rw-r--r--community/perl-data-compare/APKBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/community/perl-data-compare/APKBUILD b/community/perl-data-compare/APKBUILD
index 2fa8b36a6d..1ff02b1def 100644
--- a/community/perl-data-compare/APKBUILD
+++ b/community/perl-data-compare/APKBUILD
@@ -3,42 +3,37 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-data-compare
_pkgreal=Data-Compare
-pkgver=1.25
-pkgrel=1
+pkgver=1.26
+pkgrel=0
pkgdesc="Compare perl data structures"
-url="http://search.cpan.org/dist/Data-Compare/"
+url="https://metacpan.org/release/Data-Compare"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-file-find-rule"
-cpanmakedepends=""
depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/D/DC/DCANTRELL/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/D/DC/DCANTRELL/Data-Compare-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="6db1235672030aa1afe52de1de9fac1f8a2af9eed99a3143d6c5b30669908125f584638fe06b8b33208f6d7fb734ccec7381c9411408a3f4fde1998707f748c9 Data-Compare-1.25.tar.gz"
+sha512sums="0fc8d0c3eea4d1dea7f9e4aaedba41477dae275e89781ed39e73ff75cdcc72c0051bdfe03b0f07cbd20d3b02992159597c2e485ce49868d935058524ceab58f0 Data-Compare-1.26.tar.gz"