aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-06-17 18:04:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-17 18:10:21 +0000
commitc1de8d501c273ee0093c11abcf4e53c5ec0668c7 (patch)
tree7da8079c0ced3c283b637a10766cb2cc98b1acc3
parentb0aea1e5e7e023e56c8dfd3470de7f775d5855a2 (diff)
downloadaports-c1de8d501c273ee0093c11abcf4e53c5ec0668c7.tar.bz2
aports-c1de8d501c273ee0093c11abcf4e53c5ec0668c7.tar.xz
main/imagemagic: disable flaky test
The avaraging tests seems to be flaky due to rounding errors. Test fails on x86 and s390x https://github.com/ImageMagick/ImageMagick/issues/1576#issuecomment-494595404
-rw-r--r--main/imagemagick/APKBUILD6
-rw-r--r--main/imagemagick/disable-avaraging-tests.patch26
2 files changed, 30 insertions, 2 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index 89277826c3..c53ab111de 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -17,7 +17,8 @@ makedepends="zlib-dev libpng-dev libjpeg-turbo-dev freetype-dev fontconfig-dev
libheif-dev"
checkdepends="freetype fontconfig ghostscript ghostscript-fonts lcms2 graphviz"
subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs $pkgname-perlmagick:_perlmagick $pkgname-perlmagick-doc:_perlmagick_doc"
-source="https://www.imagemagick.org/download/releases/ImageMagick-$_pkgver.tar.xz"
+source="https://www.imagemagick.org/download/releases/ImageMagick-$_pkgver.tar.xz
+ disable-avaraging-tests.patch"
builddir="$srcdir/ImageMagick-${_pkgver}"
# secfixes:
@@ -103,4 +104,5 @@ _perlmagick_doc() {
make -j1 DESTDIR="$subpkgdir" doc_vendor_install
}
-sha512sums="8dd4a45f4d95d949bcd797f44d1602a3767386ee7d73888fb8a1ee6d4d8be7c4881a88262e7261a253da6f4b3c8ac9442d5eacb44e267e2d25e11bda10b12526 ImageMagick-7.0.8-49.tar.xz"
+sha512sums="8dd4a45f4d95d949bcd797f44d1602a3767386ee7d73888fb8a1ee6d4d8be7c4881a88262e7261a253da6f4b3c8ac9442d5eacb44e267e2d25e11bda10b12526 ImageMagick-7.0.8-49.tar.xz
+58afb2da075a6208b6a990ff297b3a827d260687c3355198a8b4d987e1596c0b0cd78aff6f0be0e1896e537fbe44a3d467473183f5f149664ea6e6fb3d3291a9 disable-avaraging-tests.patch"
diff --git a/main/imagemagick/disable-avaraging-tests.patch b/main/imagemagick/disable-avaraging-tests.patch
new file mode 100644
index 0000000000..8e715f81e6
--- /dev/null
+++ b/main/imagemagick/disable-avaraging-tests.patch
@@ -0,0 +1,26 @@
+The avaraging tests seems to be flaky due to rounding errors. Test fails on
+x86 and s390x
+
+https://github.com/ImageMagick/ImageMagick/issues/1576#issuecomment-494595404
+
+diff --git a/Magick++/tests/tests.tap b/Magick++/tests/tests.tap
+index b5c15ff..bb83980 100755
+--- a/Magick++/tests/tests.tap
++++ b/Magick++/tests/tests.tap
+@@ -8,14 +8,14 @@
+ #
+ subdir=Magick++/tests
+ . ./common.shi
+-echo "1..13"
++echo "1..12"
+
+ SRCDIR=${top_srcdir}/${subdir}/
+ export SRCDIR
+
+ cd ${subdir} || exit 1
+
+-for mytest in appendImages attributes averageImages coalesceImages coderInfo color colorHistogram exceptions geometry montageImages morphImages readWriteBlob readWriteImages
++for mytest in appendImages attributes coalesceImages coderInfo color colorHistogram exceptions geometry montageImages morphImages readWriteBlob readWriteImages
+ do
+ ./${mytest} && echo "ok" || echo "not ok"
+ done