aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-06-17 15:42:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-06-17 15:35:57 +0200
commitc45742214175a0666b4169053401adfdc9a2d31e (patch)
tree749e9a39afbff32ac01a8656ea1840d8c7bbee11
parentd9caae9c5219bb034ae8a7e3d04e9485b9d5cd15 (diff)
downloadaports-c45742214175a0666b4169053401adfdc9a2d31e.tar.bz2
aports-c45742214175a0666b4169053401adfdc9a2d31e.tar.xz
main/libgit2: upgrade to 0.27.2
-rw-r--r--main/libgit2/APKBUILD8
-rw-r--r--main/libgit2/build-both-static-dynamic.patch6
-rw-r--r--main/libgit2/libressl-2.7.patch11
3 files changed, 6 insertions, 19 deletions
diff --git a/main/libgit2/APKBUILD b/main/libgit2/APKBUILD
index e3333029df..5ad7f210da 100644
--- a/main/libgit2/APKBUILD
+++ b/main/libgit2/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Pierre-Gilas MILLON <pgmillon@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgit2
-pkgver=0.27.0
+pkgver=0.27.2
pkgrel=0
pkgdesc="A linkable library for Git"
url="https://libgit2.github.com/"
@@ -15,7 +15,6 @@ subpackages="$pkgname-dev $pkgname-tests::noarch"
provides="$pkgname-libs" # for backward compatibility with v3.4
replaces="$pkgname-libs" # for backward compatibility with v3.4
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
- libressl-2.7.patch
build-both-static-dynamic.patch
"
options="!check" # FIXME some tests fails
@@ -58,6 +57,5 @@ tests() {
cp -a "$builddir"/tests "$subpkgdir"/usr/src/$pkgname/
}
-sha512sums="1304f0b6182e1e6e7fccbec1a568aefb662e144a1aea4fff5901f3c012ff0f3d28720f17d19b9a1bc6c892c32fe602766fe98a15538a94a468d65d3e4a1680ca libgit2-0.27.0.tar.gz
-274746c3ba20309a1d4a53e9843fd411abb06e7dbc5a16c179757522c395f11f54d49358e73513be3fe7e857b5b547cf6c4cfaf79963518e75c8849a41f2cfef libressl-2.7.patch
-dab2acb9a2e8a2d372ed3819edf939445a7ed626a17eec613aeb827835703f37311c4136863605b547960d10844a753a3106f5ad22a20e0aee9f2b14f4ddf5eb build-both-static-dynamic.patch"
+sha512sums="4fa2b6c1bb340d5dbc3106ababb630a4634cee2415d478be986d315ef9c659d772574a56f0b8fa77d26bd793aea92893fddf64b5f21d7c965069f928b9ce5cff libgit2-0.27.2.tar.gz
+268e24554282666900a2179a368dc2569cb3bce60ffea187fd53de1bc119a85abc02cddd8be2ab607d44db793c4807acdbb49fc5d1badfc08bf382fa511d7b3e build-both-static-dynamic.patch"
diff --git a/main/libgit2/build-both-static-dynamic.patch b/main/libgit2/build-both-static-dynamic.patch
index 210054ed45..9912727a6b 100644
--- a/main/libgit2/build-both-static-dynamic.patch
+++ b/main/libgit2/build-both-static-dynamic.patch
@@ -24,10 +24,10 @@ This is very hack-ish, it makes option BUILD_SHARED_LIBS unusable.
OPTION( ENABLE_REPRODUCIBLE_BUILDS "Enable reproducible builds" OFF )
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -415,9 +415,12 @@
+@@ -407,9 +407,12 @@
+ ENDIF()
# Compile and link libgit2
- LINK_DIRECTORIES(${LIBGIT2_LIBDIRS})
-ADD_LIBRARY(git2 ${WIN_RC} ${LIBGIT2_OBJECTS})
+ADD_LIBRARY(git2 SHARED ${WIN_RC} ${LIBGIT2_OBJECTS})
TARGET_LINK_LIBRARIES(git2 ${LIBGIT2_LIBS})
@@ -38,7 +38,7 @@ This is very hack-ish, it makes option BUILD_SHARED_LIBS unusable.
SET_TARGET_PROPERTIES(git2 PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${libgit2_BINARY_DIR})
SET_TARGET_PROPERTIES(git2 PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${libgit2_BINARY_DIR})
SET_TARGET_PROPERTIES(git2 PROPERTIES ARCHIVE_OUTPUT_DIRECTORY ${libgit2_BINARY_DIR})
-@@ -453,7 +457,7 @@
+@@ -445,7 +448,7 @@
ENDIF ()
# Install
diff --git a/main/libgit2/libressl-2.7.patch b/main/libgit2/libressl-2.7.patch
deleted file mode 100644
index 6bf1af1eb4..0000000000
--- a/main/libgit2/libressl-2.7.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/streams/openssl.h
-+++ b/src/streams/openssl.h
-@@ -31,7 +31,7 @@
-
-
-
--# if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+# if OPENSSL_VERSION_NUMBER < 0x10100000L
-
- GIT_INLINE(BIO_METHOD*) BIO_meth_new(int type, const char *name)
- {