aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-27 12:52:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-27 13:10:57 +0000
commitc4c9fd3a4232584fffbe386e7fc4c98dfb3534b4 (patch)
tree08ea19fe4b35cd80ad45e727041754ab47cda8be
parentf429b184dd2e50c48ad32225b1128a468c95cda8 (diff)
downloadaports-c4c9fd3a4232584fffbe386e7fc4c98dfb3534b4.tar.bz2
aports-c4c9fd3a4232584fffbe386e7fc4c98dfb3534b4.tar.xz
testing/bluez-hcidump,gnokii,gvfs,libsyncml,*obex*: rebuild
-rw-r--r--testing/bluez-hcidump/APKBUILD23
-rw-r--r--testing/bluez-hcidump/ntoh64.patch19
-rw-r--r--testing/gnokii/APKBUILD2
-rw-r--r--testing/gvfs/APKBUILD2
-rw-r--r--testing/libsyncml/APKBUILD2
-rw-r--r--testing/obex-data-server/APKBUILD2
-rw-r--r--testing/obexd/APKBUILD2
-rw-r--r--testing/obexftp/APKBUILD2
-rw-r--r--testing/openobex/APKBUILD2
9 files changed, 44 insertions, 12 deletions
diff --git a/testing/bluez-hcidump/APKBUILD b/testing/bluez-hcidump/APKBUILD
index 7f300493e9..09b7092095 100644
--- a/testing/bluez-hcidump/APKBUILD
+++ b/testing/bluez-hcidump/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez-hcidump
pkgver=2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Bluetooth HCI package analyzer"
url="http://www.bluez.org/"
arch="all"
@@ -9,10 +9,22 @@ license="GPL2"
depends=
makedepends="bluez-dev"
subpackages="$pkgname-doc"
-source="http://www.kernel.org/pub/linux/bluetooth/bluez-hcidump-$pkgver.tar.gz"
+source="http://www.kernel.org/pub/linux/bluetooth/bluez-hcidump-$pkgver.tar.gz
+ ntoh64.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure --prefix=/usr \
--mandir=/usr/share/man \
|| return 1
@@ -20,7 +32,8 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="5c2e3ef0a68b2845047867ba51ff8ac9 bluez-hcidump-2.0.tar.gz"
+md5sums="5c2e3ef0a68b2845047867ba51ff8ac9 bluez-hcidump-2.0.tar.gz
+fee39a3c089125cdc9f7b01f84ea8b33 ntoh64.patch"
diff --git a/testing/bluez-hcidump/ntoh64.patch b/testing/bluez-hcidump/ntoh64.patch
new file mode 100644
index 0000000000..6ab411f54b
--- /dev/null
+++ b/testing/bluez-hcidump/ntoh64.patch
@@ -0,0 +1,19 @@
+--- ./src/hcidump.c.orig
++++ ./src/hcidump.c
+@@ -51,6 +51,8 @@
+ #include "parser/sdp.h"
+
+ #if __BYTE_ORDER == __LITTLE_ENDIAN
++#if 0
++/* defined in bluetooth.h from bluez */
+ static inline uint64_t ntoh64(uint64_t n)
+ {
+ uint64_t h;
+@@ -59,6 +61,7 @@
+ h |= tmp << 32;
+ return h;
+ }
++#endif
+ #elif __BYTE_ORDER == __BIG_ENDIAN
+ #define ntoh64(x) (x)
+ #else
diff --git a/testing/gnokii/APKBUILD b/testing/gnokii/APKBUILD
index 6a0941b404..ae8c35498c 100644
--- a/testing/gnokii/APKBUILD
+++ b/testing/gnokii/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnokii
pkgver=0.6.30
-pkgrel=0
+pkgrel=1
pkgdesc="Tools and user space driver for use with mobile phones"
url="http://www.gnokii.org/"
arch="all"
diff --git a/testing/gvfs/APKBUILD b/testing/gvfs/APKBUILD
index b3c341582b..ea5e22de26 100644
--- a/testing/gvfs/APKBUILD
+++ b/testing/gvfs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gvfs
pkgver=1.7.2
-pkgrel=0
+pkgrel=1
pkgdesc="Backends for the gio framework in GLib"
url="http://ftp.gnome.org/pub/gnome/sources/gvfs/${pkgver%.*}/"
arch="all"
diff --git a/testing/libsyncml/APKBUILD b/testing/libsyncml/APKBUILD
index 5a7e1b6fb9..550f4b40f4 100644
--- a/testing/libsyncml/APKBUILD
+++ b/testing/libsyncml/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsyncml
pkgver=0.5.4
-pkgrel=0
+pkgrel=1
pkgdesc="Implementation of the SyncML protocol"
url="http://libsyncml.opensync.org/"
arch="all"
diff --git a/testing/obex-data-server/APKBUILD b/testing/obex-data-server/APKBUILD
index d0ea7f2b1c..bb09445d5c 100644
--- a/testing/obex-data-server/APKBUILD
+++ b/testing/obex-data-server/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=obex-data-server
pkgver=0.4.5
-pkgrel=0
+pkgrel=1
pkgdesc="D-Bus service for Obex access"
url="http://wiki.muiline.com/obex-data-server"
license="GPLv2+"
diff --git a/testing/obexd/APKBUILD b/testing/obexd/APKBUILD
index 7c04bb8795..5e6087284a 100644
--- a/testing/obexd/APKBUILD
+++ b/testing/obexd/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=obexd
pkgver=0.40
-pkgrel=0
+pkgrel=1
pkgdesc="D-Bus service for Obex Server"
url="http://www.bluez.org/"
arch="all"
diff --git a/testing/obexftp/APKBUILD b/testing/obexftp/APKBUILD
index 94ef144088..965f8d307d 100644
--- a/testing/obexftp/APKBUILD
+++ b/testing/obexftp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=obexftp
pkgver=0.23
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for transfer files to/from any OBEX enabled device"
url="http://openobex.triq.net/obexftp/obexftp"
arch="all"
diff --git a/testing/openobex/APKBUILD b/testing/openobex/APKBUILD
index 582dadb31e..caaecb85e7 100644
--- a/testing/openobex/APKBUILD
+++ b/testing/openobex/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openobex
pkgver=1.5
-pkgrel=2
+pkgrel=3
pkgdesc="Implementation of the OBject EXchange (OBEX) protocol"
url="http://dev.zuckschwerdt.org/openobex/"
arch="all"