aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-01-05 05:31:54 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-01-06 18:58:15 +0200
commitc696f9689ce5eb10bf27b07eb91be07bc7fcc31b (patch)
treedc7092da295a61a2b989387df7a8ef2d3fac09bc
parent0994eeee061170b1ddcd5ab02923c890715d2ab6 (diff)
downloadaports-c696f9689ce5eb10bf27b07eb91be07bc7fcc31b.tar.bz2
aports-c696f9689ce5eb10bf27b07eb91be07bc7fcc31b.tar.xz
community/php7-pecl-msgpack: disable aarch64 and armv7 test
Removed test considers aarch64 and armv7 serialize() slow
-rw-r--r--community/php7-pecl-msgpack/APKBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/community/php7-pecl-msgpack/APKBUILD b/community/php7-pecl-msgpack/APKBUILD
index 57f0047089..c6567ecfa2 100644
--- a/community/php7-pecl-msgpack/APKBUILD
+++ b/community/php7-pecl-msgpack/APKBUILD
@@ -29,6 +29,9 @@ check() {
cd "$builddir"
# Tests require session and sockets extensions which are not bundled
sed -i 's#PHP_TEST_SHARED_EXTENSIONS = `#PHP_TEST_SHARED_EXTENSIONS = -d extension=/usr/lib/php7/modules/session.so -d extension=/usr/lib/php7/modules/sockets.so `#' Makefile
+ case "$CARCH" in
+ aarch64 | armv7) rm -f tests/035.phpt # https://github.com/msgpack/msgpack-php/issues/123#issuecomment-451620789 ;;
+ esac
make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}