aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-05-03 14:34:00 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-03 14:34:00 +0000
commitc7641b8fc846d35d5f253b683c8e4b7d9eb50012 (patch)
treec2f806778218294933fec96b963d0107d7eec706
parentb9938b2aaf30b5951ed0b2d78132a624d6f85945 (diff)
downloadaports-c7641b8fc846d35d5f253b683c8e4b7d9eb50012.tar.bz2
aports-c7641b8fc846d35d5f253b683c8e4b7d9eb50012.tar.xz
testing/mlocate: attempt fix build on ppc64le, add check()
-rw-r--r--testing/mlocate/APKBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/testing/mlocate/APKBUILD b/testing/mlocate/APKBUILD
index 13cd25a8bb..d992d6a7c2 100644
--- a/testing/mlocate/APKBUILD
+++ b/testing/mlocate/APKBUILD
@@ -4,13 +4,14 @@
pkgname=mlocate
pkgver=0.26
-pkgrel=5
-pkgdesc='A utility for finding files by name quickly'
-url='https://pagure.io/mlocate'
-arch='all'
-license='GPL2'
-options='suid'
-pkggroups='locate'
+pkgrel=6
+pkgdesc="A utility for finding files by name quickly"
+url="https://pagure.io/mlocate"
+arch="all"
+license="GPL2"
+options="suid"
+checkdepends="bash"
+pkggroups="locate"
install="$pkgname.pre-install"
subpackages="$pkgname-doc"
source="https://releases.pagure.org/mlocate/$pkgname-$pkgver.tar.xz
@@ -23,16 +24,26 @@ prepare() {
cd "$builddir"
sed -i '/^groupname /s/mlocate/locate/' Makefile.in
+ update_config_sub
}
build() {
cd "$builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --target=$CTARGET \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib
make || return 1
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install