aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-24 16:20:41 +0300
committerprspkt <prspkt@protonmail.com>2019-06-24 17:33:32 +0300
commitc791149a250b8a7f46db092cf0ede285965d23cb (patch)
tree8ea8c8cd82d15e08c2f79eb664d037a692495ed1
parent248c4d88989a19c755458620b6855d04cd9d8aec (diff)
downloadaports-c791149a250b8a7f46db092cf0ede285965d23cb.tar.bz2
aports-c791149a250b8a7f46db092cf0ede285965d23cb.tar.xz
testing/py-dulwich: drop python2
-rw-r--r--testing/py3-dulwich/APKBUILD (renamed from testing/py-dulwich/APKBUILD)28
1 files changed, 6 insertions, 22 deletions
diff --git a/testing/py-dulwich/APKBUILD b/testing/py3-dulwich/APKBUILD
index afec67e9cb..f081912f16 100644
--- a/testing/py-dulwich/APKBUILD
+++ b/testing/py3-dulwich/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-dulwich
+pkgname=py3-dulwich
_pkgname=dulwich
pkgver=0.19.10
pkgrel=1
@@ -9,14 +9,15 @@ url="https://www.dulwich.io"
arch="all"
license="GPL-2.0-or-later or Apache-2.0"
options="!check" # Tests are failing (http-backend)
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="py3-setuptools python3-dev"
source="https://github.com/dulwich/dulwich/archive/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-dulwich-$pkgver
+replaces="py-dulwich" # Backwards compatibility
+provides="py-dulwich=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
@@ -27,25 +28,8 @@ build() {
#}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python=$1
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
sha512sums="0699e7cdea103f2caca24b7841d2cb761d264d3847c22ceb74b5c3f9a890ad8143dad5affd339da424b38c1b13e55788b2d521797b9653a7ff7c373ab02b2401 dulwich-0.19.10.tar.gz"