aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-12-07 15:11:49 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-12-07 16:18:27 +0100
commitc7f8c1953e3384498e98c992b1f58c6329e499fb (patch)
tree876650bbb4ac0e3bf427bf724fa23af7e7604cae
parentb231d456ceca45c7befa2586d65281144ee20b3e (diff)
downloadaports-c7f8c1953e3384498e98c992b1f58c6329e499fb.tar.bz2
aports-c7f8c1953e3384498e98c992b1f58c6329e499fb.tar.xz
testing/kea: port debian patches fixing lockfile and pidfile locations
-rw-r--r--testing/kea/APKBUILD4
-rw-r--r--testing/kea/put-LOCKFILE_DIR-to-runstatedir.patch16
-rw-r--r--testing/kea/use-runstatedir-for-pid-file-location.patch34
3 files changed, 54 insertions, 0 deletions
diff --git a/testing/kea/APKBUILD b/testing/kea/APKBUILD
index a9d588e38b..235555f025 100644
--- a/testing/kea/APKBUILD
+++ b/testing/kea/APKBUILD
@@ -32,6 +32,8 @@ subpackages="
source="https://ftp.isc.org/isc/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
disable-db-tests.patch
logs-location.patch
+ use-runstatedir-for-pid-file-location.patch
+ put-LOCKFILE_DIR-to-runstatedir.patch
kea.initd.in
"
validpgpkeys="BE0E9748B718253A28BB89FFF1B11BF05CF02E57" # Internet Systems Consortium, Inc. (Signing key, 2017-2018) <codesign@isc.org>
@@ -173,4 +175,6 @@ _install_initd() {
sha512sums="f84bed2e1dacd172c7aed8e4d6c11ec5e79f37ad2c7991963fc9c4a1761668f9f0e105ba5c4deed06264ab2ec13b1b5787350d823de12fd3782223192e3653f2 kea-1.7.2.tar.gz
55780bbcbd79b81d55bdccd46da6ca6babe8b7894aa82948308dc4f8a0e2b5d33fad633276696c8ba7bd063026bb11ae529a096375d0572833c66e2132888775 disable-db-tests.patch
4336bb6708d51729065da4dd3a3e96bbcbac7716b4bbde360af3c4599719c2fa9362055ae6c00043e7581f2f4af5a51d24f2e8cfaabefdb1f4d545c24af33f94 logs-location.patch
+574b4aacef03c2d4a556b4ff8b152b66efd6fdc27ad09373d41c72df15f8a2cd2386e0bbe7e07f1370d9cd11e0954fc679f3d57e6b647d601cc06e0c63bc8712 use-runstatedir-for-pid-file-location.patch
+062e6eb88c49aeeac5d78c37c43cda1ff753e19f833aaa1525e37f66eede819910d4849bd954f3ef8ceb1b13e747953c99e2a9a4d9755b6da8d82c4e08b2b55c put-LOCKFILE_DIR-to-runstatedir.patch
57bed5c19aeb03218228a0b1244e7036ed80eaacb55e9799c9ba86619662f34c858512212b69b30c11b9b592ff776a82193ccd6fccffb6b3daa016e6d9197528 kea.initd.in"
diff --git a/testing/kea/put-LOCKFILE_DIR-to-runstatedir.patch b/testing/kea/put-LOCKFILE_DIR-to-runstatedir.patch
new file mode 100644
index 0000000000..965c5e5829
--- /dev/null
+++ b/testing/kea/put-LOCKFILE_DIR-to-runstatedir.patch
@@ -0,0 +1,16 @@
+This patch is based on https://sources.debian.org/src/isc-kea/1.5.0-2/debian/patches/0005-Put-KEA_LOCKFILE_DIR-to-runstatedir.patch/
+
+We have to modify the autohelled Makefile.in instead of Makefile.am because Kea
+requires old automake-1.15.
+
+--- a/src/lib/log/interprocess/Makefile.in
++++ b/src/lib/log/interprocess/Makefile.in
+@@ -434,7 +434,7 @@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = . tests
+ AM_CPPFLAGS = -I$(top_srcdir)/src/lib -I$(top_builddir)/src/lib \
+- -DLOCKFILE_DIR=\"$(localstatedir)/run/$(PACKAGE_NAME)\" \
++ -DLOCKFILE_DIR=\"$(runstatedir)/$(PACKAGE_NAME)\" \
+ $(BOOST_INCLUDES)
+ AM_CXXFLAGS = $(KEA_CXXFLAGS)
+ CLEANFILES = *.gcno *.gcda
diff --git a/testing/kea/use-runstatedir-for-pid-file-location.patch b/testing/kea/use-runstatedir-for-pid-file-location.patch
new file mode 100644
index 0000000000..146026b5e0
--- /dev/null
+++ b/testing/kea/use-runstatedir-for-pid-file-location.patch
@@ -0,0 +1,34 @@
+From: =?utf-8?b?T25kxZllaiBTdXLDvQ==?= <ondrej@sury.org>
+Date: Tue, 19 Feb 2019 12:55:42 +0000
+Subject: Use runstatedir for pid file location
+
+We have to modify the autohelled Makefile.in instead of Makefile.am because Kea
+requires old automake-1.15.
+
+Patch-Source: https://sources.debian.org/src/isc-kea/1.5.0-2/debian/patches/0004-Use-runstatedir-for-pid-file-location.patch/
+
+--- a/src/lib/process/Makefile.in
++++ b/src/lib/process/Makefile.in
+@@ -487,10 +487,8 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = . testutils tests
+-# DATA_DIR is the directory where to put PID files.
+-dhcp_data_dir = @runstatedir@/@PACKAGE@
+ AM_CPPFLAGS = -I$(top_builddir)/src/lib -I$(top_srcdir)/src/lib \
+- -DDATA_DIR="\"$(dhcp_data_dir)\"" $(BOOST_INCLUDES)
++ -DKEA_PIDFILE_DIR="\"$(runstatedir)/$(PACKAGE_NAME)\"" $(BOOST_INCLUDES)
+ AM_CXXFLAGS = $(KEA_CXXFLAGS)
+
+ # Ensure that the message file is included in the distribution
+--- a/src/lib/process/daemon.cc
++++ b/src/lib/process/daemon.cc
+@@ -37,7 +37,7 @@
+
+ Daemon::Daemon()
+ : signal_set_(), signal_handler_(), config_file_(""),
+- pid_file_dir_(DATA_DIR), pid_file_(), am_file_author_(false) {
++ pid_file_dir_(KEA_PIDFILE_DIR), pid_file_(), am_file_author_(false) {
+
+ // The pid_file_dir can be overridden via environment variable
+ // This is primarily intended to simplify testing